Maximize my website speed

Hello,

I have a question regarding the DNS settings on my website. I have attached a screenshot for your reference, and I was hoping you could provide some guidance on how to optimize my website’s speed and make it as fast as possible. I use WordPress and OptimizePress as my page builder, and FunnelFlux to track everything.

Any advice or recommendations you could offer would be greatly appreciated.

Thank you!

Greetings,

Thank you for asking.

At first sight, from the shared screenshot, the A greatinfohacks.com and CNAME www should be proxied :orange: so the Cloudflare optimizations, security and other features could be applied.

I’d like to share my post from below which covers quite good features which could help in your case too :slight_smile:

Here around :orange: Communtiy are quite a lot of different topics. I’d give it a try to use the search :search: to find some cases and gather more information.

Just in case if you encouter some issues and/or errors, since it’s related to the WordPress, I’d suggest you to allowlist your origin host / server / hosting IP address by navigating to the Security → WAF → Tools → IP Access Rules with the action “allow” for your Website and try again.

It knows to happen due to the WordPress using HTTP/1.0 and empty user-agent, therefore while executing WP-Cron or some other related JSON/REST API request via plugin which triggers the WAF rules (as it should normally).

Since you’re using some kind of a Website Builder plugin, the “Rocket Loader” feature could be in a conflict with the JavaScript and being enabled at Cloudflare dashboard → Speed → Optimization :thinking:

May I ask, have you tried disabling the Rocket Loader feature at the Cloudflare dashboard? :thinking:

It might be some conflict with the scripts while loading them.

May I also ask if you’ve got Auto Minify options enabled for HTML, CSS & JS at Cloudflare dashboard? Try disabling them too.

Kindly, may I ask you to check out what option have you got selected by navigating to the Cloudflare dashboard → Caching → Configuration → find section “Browser Cache TTL” and make sure the selected option from the dropdown menu is “Respect Existing Headers”.

Furthermore, from the same menu, click on the blue button saying “Purge Everything” to flush the cache at Cloudflare Edge, just in case.

Wait for a minute or two.

Refresh a page in your Web browser, otherwise try clearing your Web browser cache or use a different Web browser to test out again.

Also, if you checked your Developer Console (F12), are there any error and/or warnings?

Otherwise, maybe the “Auto Minify” for HTML, CSS and/or JavaScript is checked at Cloudflare dashboard → Speed → Optimization, and makes some issues :thinking:

Please, feel free to reply and ask more questions as you try those features or have some co-related questions you’d like to get an answer.

2 Likes

This is my loading time on mobile mode

The desktop version of the website is performing well, with a score of 98.

I apologize for my lack of familiarity with Cloudflare, as I’m not very tech-savvy. However, I was wondering if it’s possible to achieve a similar score on mobile devices as well? Currently, the mobile version of the website seems to be slower.

:point_up: is always tricky due to the JavaScript :thinking:

From my experience, the Pro Plan offers great features for visitors coming to your Website from mobile, like TCP Turbo, Mirage, Polish, etc.

Would also have to test a bit things and tweak a bit, of course, to get the best possible outcome :wink:

What score number can I reach on mobile in my case?

Ye, we all look for the numbers :slight_smile:

I cannot guarantuee, however we could try to tweek and tune things at Cloudflare dashboard and test test test to se how does it go.

Might have to take a deeper insight look into what issues you’re currently having and determine what options have you got :thinking:

We don’t want to remove things from your Website, since we might “have to” because Google tool says it - not the best practice always.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.