Massive packet loss between EU-Singapore

Hi community! Since a month ago, traffic between EU and Singapore routing through telstraglobal there was issues with randomly massive packet loss(90% ~ 99%).

Does anyone else have the same problem?

MTR:
HOST: Loss% Snt Last Avg Best Wrst StDev
1.|-- gateway 0.0% 200 49.0 15.2 0.5 233.0 44.2
2.|-- bg1.dus2.de.as29141.net (5.45.181.211) 0.0% 200 0.5 3.3 0.4 64.6 9.1
3.|-- bg1.ams1.nl.as29141.net (5.45.181.213) 0.0% 200 4.5 7.3 4.3 67.6 9.3
4.|-- ae12-435.ams10.core-backbone.com (5.56.20.177) 0.0% 200 5.0 6.1 4.9 81.0 6.2
5.|-- 80.249.212.88 0.0% 200 27.6 29.6 27.3 71.7 7.1
6.|-- unknown.telstraglobal.net (202.84.178.53) 99.5% 200 157.7 157.7 157.7 157.7 0.0
7.|-- i-10147.unse-core01.telstraglobal.net (202.84.141.145) 99.5% 200 157.1 157.1 157.1 157.1 0.0
8.|-- ??? 100.0 200 0.0 0.0 0.0 0.0 0.0
9.|-- i-0-3-0-2.1wlt-core02.telstraglobal.net (202.84.143.202) 99.5% 200 158.9 158.9 158.9 158.9 0.0
10.|-- ??? 100.0 200 0.0 0.0 0.0 0.0 0.0
11.|-- ??? 100.0 200 0.0 0.0 0.0 0.0 0.0
12.|-- ??? 100.0 200 0.0 0.0 0.0 0.0 0.0
13.|-- i-93.istt04.telstraglobal.net (202.84.224.190) 99.5% 200 347.6 347.6 347.6 347.6 0.0
14.|-- ??? 100.0 200 0.0 0.0 0.0 0.0 0.0
15.|-- 172.69.135.33 99.5% 200 271.7 271.7 271.7 271.7 0.0


HOST: Loss% Snt Last Avg Best Wrst StDev
1.|-- gateway 2.4% 500 0.7 13.9 0.5 370.0 40.7
2.|-- bg1.dus2.de.as29141.net (5.45.181.211) 0.0% 500 0.8 3.0 0.5 77.0 9.9
3.|-- bg1.ams1.nl.as29141.net (5.45.181.213) 0.0% 500 4.7 6.4 4.4 66.9 8.6
4.|-- ae12-435.ams10.core-backbone.com (5.56.20.177) 0.0% 500 5.2 5.7 4.9 34.3 2.4
5.|-- 80.249.212.88 0.0% 500 27.7 28.7 27.2 69.6 5.7
6.|-- unknown.telstraglobal.net (202.84.178.65) 99.8% 500 163.2 163.2 163.2 163.2 0.0
7.|-- i-13.unse-core01.telstraglobal.net (202.84.252.89) 99.4% 500 7570. 2631. 162.5 7570. 4276.9
8.|-- 172.69.135.33 99.8% 500 4581. 4581. 4581. 4581. 0.0
9.|-- ??? 100.0 500 0.0 0.0 0.0 0.0 0.0
10.|-- ??? 100.0 500 0.0 0.0 0.0 0.0 0.0
11.|-- i-0-3-0-2.1wlt-core02.telstraglobal.net (202.84.143.202) 99.8% 500 357.1 357.1 357.1 357.1 0.0
12.|-- i-15006.sgpl-core02.telstraglobal.net (202.84.140.233) 99.6% 500 398.5 376.6 354.8 398.5 30.9
13.|-- i-15006.sgpl-core02.telstraglobal.net (202.84.140.233) 99.6% 500 3096. 1724. 353.0 3096. 1939.8
14.|-- i-93.istt04.telstraglobal.net (202.84.224.190) 99.8% 500 356.2 356.2 356.2 356.2 0.0
15.|-- unknown.telstraglobal.net (210.57.30.162) 99.8% 500 368.9 368.9 368.9 368.9 0.0
16.|-- 172.69.135.234 99.6% 500 1246. 762.9 279.3 1246. 683.9


HOST: Loss% Snt Last Avg Best Wrst StDev
1.|-- gateway 2.5% 200 0.6 19.7 0.5 358.8 51.7
2.|-- bg1.dus2.de.as29141.net (5.45.181.211) 0.0% 200 0.5 2.7 0.5 59.0 9.1
3.|-- bg1.ams1.nl.as29141.net (5.45.181.213) 0.0% 200 9.0 7.0 4.4 70.7 9.3
4.|-- ae12-435.ams10.core-backbone.com (5.56.20.177) 0.0% 200 5.2 6.7 4.9 56.8 5.8
5.|-- 80.249.212.88 0.0% 200 27.5 29.1 27.2 95.4 7.6
6.|-- unknown.telstraglobal.net (202.84.178.65) 0.0% 200 162.1 162.0 161.8 163.8 0.2
7.|-- i-13.unse-core01.telstraglobal.net (202.84.252.89) 0.0% 200 163.4 163.7 161.8 166.5 1.2
8.|-- i-1.tlot-core02.telstraglobal.net (202.84.252.85) 0.0% 200 162.4 163.3 162.1 164.6 0.7
9.|-- i-1.tlot-core02.telstraglobal.net (202.84.252.85) 0.0% 200 164.9 165.3 164.1 166.8 0.6
10.|-- i-0-3-0-2.1wlt-core02.telstraglobal.net (202.84.143.202) 0.0% 200 165.5 165.3 164.2 166.6 0.6
11.|-- i-0-3-0-2.1wlt-core02.telstraglobal.net (202.84.143.202) 0.0% 200 355.4 356.2 354.8 358.4 0.7
12.|-- i-15006.sgpl-core02.telstraglobal.net (202.84.140.233) 0.0% 200 353.1 353.2 351.8 360.4 1.3
13.|-- i-15006.sgpl-core02.telstraglobal.net (202.84.140.233) 0.0% 200 354.0 354.2 352.3 373.2 3.3
14.|-- i-93.istt04.telstraglobal.net (202.84.224.190) 0.0% 200 354.5 355.3 354.4 378.7 3.3
15.|-- unknown.telstraglobal.net (210.57.30.162) 44.0% 200 349.3 318.5 277.4 394.6 33.8
16.|-- 172.69.135.31 0.0% 200 273.4 273.4 273.4 275.4 0.2

Where’s the Singapore in this mix?

My server is located in Germany, massive packet loss with Cloudflare Singapore.

Also, I tested with server located in Czech Republic, same problem there. (routing through telstraglobal)

How are you connecting to Cloudflare in Singapore to test this packet loss?

I pined the Cloudflare Singapore IP address and checked with MTR.

Cloudflare connects to my server through these IPs. From a month ago I found a lot of 522 errors from SIN colo.

Sorry so are you trying to diagnose / report an issue between your client machine in the Singapore area and Cloudflare’s edge network?

This appears to be some type of test that originates in Europe based on the first couple of hostnames so that’s why I’m confused.

The network between my client machine and Cloudflare Singapore is working properly.

But there is a problem with the network between my server(located in EU) and Cloudflare Singapore.

So I pinged the IP of Cloudflare Singapore through my server located in EU and found the massive packet loss.

How do you know the IP address of Cloudflare Singapore? Cloudflare uses an Anycast network, so it’s the same IP address all over the world, regardless of datacenter location.

Client <—> Cloudflare Singapore colo <—> Germany

When the client visits the website through Singapore colo(checked with cdn-cgi/trace), Cloudflare sends the request from Singapore colo to my server.

Because these requests have a large number of 522 errors. So I tried to diagnose the IP of the request sent by Cloudflare.

I can confirm that these requests are coming from Singapore colo via MTR.

Hi,

Also experienced this issue before last week. It was related to the SMW5 cable cut. Fortunately, I was rerouted via NTT/Telia to CF singapore’s colo.

are you still having issues until now?

Yes. Mine is not rerouted :frowning:

Edge servers also has a unicast IP. Other wise client request redirected near server but packet cannot establish right edge server.

Client(Unicast) <—> (Anycast)Cloudflare(Unicast)<—> (Unicast or Anycast)Webserver

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.