Mass DNS records being imported

can some body please explain in plain english how to do this?

Hi can anyone show how to delete mass dns records in simple plain english?

You need to write a script to use the API, or use one that someone else has written.

You might see if one of the tools here will meet your needs.

https://cloudflare-utils.cyberjake.xyz/

Hi thanks

tried that without success…through SSH on my plesk server as well as command line in windows

what i need is a clear explanation of how to use all that curl stuff…i am a novice…but really need to delete the 965 dns records
that were installed

cheers and thanks
chris

You shouldn’t need to do anything with curl if you downloaded cloudflare-utils. You will need an API token with the permissions listed at the top of this guide.

DNS Purge - Cloudflare Utilities

You may need to wait for this outage to be resolved.

1 Like

Hi…
i downloaded and looked at that but couldn’t seem to find the .exe file to run it?
so not really sure where to go with it

cheers

If you downloaded a Windows version it would have been a ZIP file with an EXE file inside it along with a LICENSE file and a README.md. You would find the EXE in whatever folder you extracted it into from the ZIP file.

it was a windows version and defo no exe file in the zip

so still a bit confused

cheers

Perhaps you downloaded the source code rather than the Windows binary. I downloaded the 64 bit Windows version (cloudflare-utils_1.1.3_windows_amd64.zip) from the releases page on Github and it contains an EXE as well the LICENSE and README.md files.

1 Like

Hi

yes have since downloaded that but for some reason the .exe file does not execute on my laptop.
and its defo a 64 bit processo not a 32…??

cheers

I didn’t download it on Windows, so I was not in a position to do more than examine the contents of the ZIP.

Are you running it from either a CMD or PowerShell terminal?

Hi…tried via windows command line and no joy…
dont know how to run in Powershell?

cheers----- Original Message -----

Do you get any output or error message?

Hi… dont get anything what so ever…
just doesn’t seem to want to execute, i am at a loss?
error message from command line is something like …‘.this is not recognized as an internal or external command, operqaqble program
or batch file’

cheers

.

Are you running the command from the folder you unzipped into? Are you using a relative path to ensure the command interpreter knows where to find the file?

e.g. %HOMEPATH%\Downloads\> .\cloudflare-utils.exe

hmmmm…

not sure to be totally honest…like i said …im’ a novice just trying to solve a problem that i didn’t create

cheers

You may need to find a trusted advisor that work with more closely than we can here in the community. We have exhausted the suggestions and prompts that I can provide here.

I’ve been meaning to build a tool to do this, but I haven’t run into the issue myself lately so it fell down my project list. I decided to try this out, I’m on Windows 11 x64.

I started by downloading cloudflare-utils_1.1.3_windows_amd64.zip and saved it into C:\Users\MyUserName\Downloads

Unzip the file into C:\Users\MyUserName\Downloads\cloudflare-utils_1.1.3_windows_amd64

Press Start and type cmd.exe

In the console window, change to the directory:
cd C:\Users\MyUserName\Downloads\cloudflare-utils_1.1.3_windows_amd64

Run the tool:
cloudflare-utils.exe

 Error running app: no authentication method detected

Next I looked at the Getting Started guide. I decided to use the not-recommended version with the API_EMAIL and _KEY as I happen to have these handy (you should do it properly, but I’m lazy) using these two commands:

set [email protected]
set CLOUDFLARE_API_KEY=MySecretApiKey

Now run the tool again to see the help page:
cloudflare-utils.exe

NAME:
   cloudflare-utils - Program for quick cloudflare utils

USAGE:
   cloudflare-utils [global options] command [command options] [arguments...]
   <...>

Now I set my domain:
set CLOUDFLARE_ZONE_NAME=example.com

And run the command:

cloudflare-utils dns-purge

It asks me to confirm, then proceeds to remove everything from my zone:

About to remove 1 records.
Continue (y/n): y
Successfully deleted all 1 dns records
1 Like

Hi
traied all methods to execute the utils file…no result
so back to manually deleting all those ridiculous dns records…only 621 to go

surely Cloudflare can put a simple button on the website to do this, not beyond the wit of man…!!

cheers

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.