Masked domains not working

Masked domains from x2 - I have changed nameservers - have included the number for the A records on cloudflare but doesn’t work. - I think the Fasthosts staff said it was showing as nameservers can’t be found. They defiantly advised I contact cloudflare and seemed to think the problem was their end. Any help??


So mine is working fine and the one I am trying to mask is called vapemysoul

What do you mean by “mask”?

So sending another domain to ftp/site and displaying(masking) the URL in the address bar of your browser to show vapemysoul rather than john_c

Well, does not appear to be set up on Cloudflare. You set the domain’s nameservers to random Cloudflare nameservers without having added it. That cannot work. Reset the nameservers to what they were before, add the domain to Cloudflare, and only then point the domain to the nameservers you were given.

That is something you need to configure on your server. Cloudflare does not support that.

1 Like

hmm, I have configured the domain on fasthosts to mask. John_C had already been added to cloudflare. I’m not really clear… I put the nameservers for the new domain back to what they were, correct?

Please read what I just wrote :wink:

What is not clear about it?

Well, vapemysoul does not appear to be set up on Cloudflare - OK, understood

You set the domain’s nameservers to random Cloudflare nameservers without having added it - I don’t understand. I had only copied the nameservers from stefancostain and put them in the nameservers for need4design

Reset the nameservers to what they were before - I guess you mean on fasthosts?
add the domain to Cloudflare - can I add a domain without a hosting package from fasthosts?

As I said you cant do that.

I dont know. Whatever they were before. Possibly your host. You need to set them to nameservers which answer for that domain.

Yes, but if the domain doesnt have any hosting associated Cloudflare wont be able to display much.

So… I added John_C to cloudflare with another domain already masked using John_C ftp. Both worked fine. The masked one masks and the John_C one work too.

Then I go and buy another domain. Then I put in the same nameserver that worked for when I changed the John_C to cloudflare.

All I am trying to ask is how to add another domain and also mask that like the other one is and you have given me info which is really not helping.

Do I have to take John_C off cloudflare then add my masked domains to John_C then add John_C back to cloudflare maybe?

You tell me to add vapemysoul and say if it doesn’t have hosting then it won’t display but the idea is to have only one hosting for John_C and the other domains using this hosting with masked addresses.

I answered that at Masked domains not working

Well, that makes it two then. I find it rude and disrespectful to ask for assistance but then not even read what people took the time to write. That on top of you apparently not reading the official documentation, otherwise you wouldnt have added random nameservers to that second domain.

Anyhow, I am really not sure what else to write as you have been giving all the information already. Your second domain’s setup simply is broken and invalid. You need to go back to the drawing board and start with the setup process from scratch, but I already explained that

As for your “masking”, as I already explained as well, that wont work. Cloudflare does not support that and you will need to do this on your server side. The other option would be to use Cloudflare Workers, however that would be mostly a paid option, depending on how many requests you expect and whether you exceed the free limit.

Overall I strongly suggest to check out as that will cover most of the questions and there is little point in expecting the forum to rehash answers for the Nth time, which cannot only be found on the support page but also via the search - and that brings us back to aforementioned respect :slight_smile:

This is usually done in an iframe set up on the masking domain’s website. And the URL bar doesn’t change, as it’s framing whatever is going on in the underlying website.

Are you trying to mask part of the john_c site? Or is vapemysoul supposed to be a clone of the john_c site, but masked?

Thanks sdayman,

I am just trying to mask part of john_c I guess. Just making a folder in the FTP of john_c and trying to divert the vapemysould to there. The masking I have set up already.
So john_c/vapemysould/index.html should load when I type into a browser
and display in the browser. All the masked bit is done on the site I got the domain from. But they have told me to contact you guys. I think they said they got “nameservers unrecognised” maybe wrong there though but something similar.

Excuse me? I explained step-by-step what you have to do and even asked you what is unclear and you did not address that. Instead you brought your other domain into the discussion. That domain is not part of the issue.

You need to set up your domain and only that domain.

I ask you again, what exactly is unclear about what I wrote earlier? You need to point the domain to where it pointed before and start the setup process from scratch. Right now your domain does not work on Cloudflare and is not set up to begin with.

Alright, whatever you say :wink:

As a starting point, I’m not getting content from the john_c site. When I connect, I get a 404 result code. Same goes for the vapemysoul subdirectory.

Hi sdayman sorry,
my site is

Sorry, that was a typo on my part. I was testing your domain as typed