Managed Network is not determined when using WARP

Hi !

I started touching Cloudflare to use ZTNA. We have an on-premise server in our company and an app server in AWS. We have created a Tunnel on the network for each of the internal and AWS servers, and users outside the company can access both servers using WARP.

When users return to the company, we want to leave the WARP client enabled, set the internal server address to exclude Split Tunnels, and continue to use ZTNA to connect to the AWS app server.
(On-premise servers and users are on the same network)

In order to identify the in-house network, we have configured Managed Network and when not connected to WARP and when connected to “Gateway with DoH”, the Managed Network, “Home Network” (HomeProfile), is identified. When connected to “Gateway with WARP”, the “Home Network” (HomeProfile) is identified as the Managed Network. When connecting to “Gateway with WARP”, the Managed Network becomes “” (Default Profile). (The IP address of the “beacon” (192.168.1.136) always specifies the Split Tunnels exclusion setting.)

What causes ManagedNetwork not to be identified when WARP is enabled? Does anyone know if it is my lack of configuration or a bug?

I am actually having the same issue.

When I’m at the office and WARP is set to ‘Paused’, the command warp-cli get-alternate-network displays “Office”.

However, when WARP is ‘Connected’, the same command shows “”. This indicates that the TLS endpoint is functioning correctly, but when WARP is connected, it seems to be using an incorrect profile.

It is resolved by upgrading the WARP client to V2023.9.248.0

1 Like