Malking Argo tunnels with Shell-in-a-box work

Did anyone succeed in using Argo Tunnels to allow access to shell-in-a-box or other ssh over https tools?

Hi Omeron

I am also looking at trying to get something like this working. Did you come up with a solution?



Hi robhudd,

Couldn’t get it to work and am searching for a different solution on this.
If you have any success here I’d love to here.


Hi Omer

I will keep trying over the next couple of days. I will let you know how I go.



Hi Omer

I got it working. I have to run to work now but I will post the solution here tonight or tomorrow morning.


Hi Omer

Here is the setup I used. You need Apache installed for this.

Setup apache
setup a conf file for shellinabox under the /etc/apache2/sites-enabled/ directory
sudo nano /etc/apache2/sites-enabled/shellinabox.conf
Add the following lines.

<Location /shellinabox>
ProxyPass https://localhost:4200/
Order allow,deny
Allow from all

Then nano /etc/apache2/sites-enabled/000-default.conf
add line in the <VirtualHost *:80> section

SSLProxyEngine On

Then enable HTTP Proxy
a2enmod proxy_http
a2enmod ssl
a2enmod headers

restart apache

then try to connect through the Cloudflare Tunnel

and you should get to the shellinabox login.

Good luck


Hi Robert,

This is really cool! Thanks a lot for sharing.