Making My Website Secure

#1

My website is up and running. I just thought that when I changed my NS’s to Cloudflare’s, that that would make my website secure (https). Is there something else I need do to make that happen? Thanks, Kirk.

0 Likes

#3

Hi @kirkygee, it does take a bit of time after you enable ssl for the certificate to issue. If you’re not seeing a secure site, clear browser cache and revisit the site. Let us know how it works out.

1 Like

#4

Hello.

I was thinking that after I changed my domain’s nameservers (DNS) over to CloudFlare, it would automatically enable ssl.

It had been over 72 hours, and still read “not secure” on my website.

Just now, I installed the CloudFlare plug-in for WordPress, and that seems to have worked.

Thanks for your email concerning this.

Kirk

1 Like

#5

Well, my website finally went to https by enabling the CloudFlare plug-in in Wordpress. An hour later I got this Entry Process Limit notification, and my site is disabled for 24 hours. Huh?

0 Likes

#6

That’s not a Cloudflare error. Which hosting company & package are you using?

1 Like

#7

Hello. I’m using a free InfinityFree account. I found the attached info from my CloudFlare account. Does this have anything to do with it, that you might know of? This happened right after I used the CloudFlare plug-in for Wordpress. Thanks for your attention. Kirk

0 Likes

#8

Also, should my SSL setting be on Flexible or Full?
Thanks, Kirk

0 Likes

#9

Free and Shared Hosting may have low maximum entry processes or concurrent connections and by the looks of it, the free option suspends the account instead of throttling it. Full or Full (Strict) if possible.
Also, if you’re not expecting traffic from that Country, you can use the Cloudflare Firewall to block it.

0 Likes

#10

Hello. This is what InfinityFree has said about the spike:

"CloudFlare didn’t work because the NS settings they pulled were wrong
Plugin or not - both uses and communicates with the same destination (CloudFlare)

What I think is happened:
You chose the wrong SSL or the default setting was incorrect (like SSL strict or Flex instead of Full)
And that is caused a CF error 520
and the plugin is then either hang or has done extra communication and worked longer than is provided/allowed - which caused the spike and suspension."

What do you think? I changed my settings to Full, and blocked Russia. Thanks, Kirk

0 Likes

closed #11

This topic was automatically closed after 30 days. New replies are no longer allowed.

0 Likes