Majority of Domains Fail to Transfer - Is This Yet Another Limit?


#1

Attempting to transfer domains, all from the same registrar, with the same unlocked status and contact details, all with the correct AUTH codes.

So far, Cloudflare has managed to successfully transfer in 9 domains.

Now, however, all further transfers seem to be failing but without any reason being indicated. Here is a screenshot of 14 failed transfers, with no reason being given:

Again, these are all from the same registrar as the domains that were accepted, with precisely the same status and details, all with correct AUTH codes, but the Cloudflare system will not accept them.

My hunch that this is due to some sort of block, rather than the details of any specific domain, is that, now, no domains work, not even ones newly added to Cloudflare.

Could someone from Cloudflare let us know if there is currently any sort of limit on the number of domains you can simultaneously transfer?

If there is, that would seem to run against the grain of the message below the failed transfers, which encourages you to add the rest of your sites to Cloudflare so that “you’ll be able to transfer them to Cloudflare Registrar immediately”.


#2

That’s what mine looked like…because all my failed domains had Dedicated SSL certificates here. So I made sure I also had Free Universal certs, deleted the dedicated certs, transferred the domains, then re-added the dedicated certs.


#3

Thanks @sdayman. In my case, I haven’t been able to detect what the cause might be, none had dedicated certs or any other difference from the successfully transferred domains. My current hunch is that they system is just flaky as Hell right now :smile:


#4

They tracked down my issue after I attached a HAR file of that failure screen in a Support Ticket.

p.s. I believe the issue was because I had extra services tacked onto that domain.


#5

It certainly seems as if they designed their registrar system to punish their biggest users :rofl:

I am spending this evening wasting hours removing hundreds of sites from Cloudflare, purely to try and get past the limitations.


#6

I also encountered such a problem, a small number of domain names can be transferred, but most of them failed to transfer.
I spent a whole day trying to keep trying, but in the end it was a failure. I feel like I’m working like a fool for a day.


#7

“Please retry transferring this domain. You have not been charged.”

Does anyone know what kind of problem this sentence represents?


#8

:wave: @Brooklyn,

I would recommend contacting support directly (and including a HAR file if possible. They can review the logs of the underlying request and give you details on what the issue might be.

https://support.cloudflare.com/hc/en-us/requests/new

-OG


#9

@OliverGrant How, exactly, do you think a HAR file will help?!

Do you understand that the problem here is that @Brooklyn is having a domain registration problem, not some sort of network routing or browser problem?

I am absolutely certain that the problems with this registration system will only be addressed if users post their experiences right here, publicly, in the forum. That is the only way that it will become clear to the designers that a domain registration system needs to accommodate the needs of domain owners.

For the purpose of transferring domains, what they have built is comically bad, even down to the most obvious requirements such as sort ordering and actually letting people pick which domains to transfer - it is almost as if none of them have ever actually used a domain registrar. It is a brutal thing to admit that you made some bad initial design choices, and it simply will not happen unless it becomes more difficult to avoid reality than accept it.

If everyone starts politely submitting support tickets (and HAR files :joy:), the designers will never have to open their eyes to the very real problems.


#10

:wave: @imappoet

Yes I do indeed. I think a HAR file might help because there are multiple potential causes for the error and for some of them a HAR file can be helpful as evidenced by @sdayman in this very thread.

You do realize they are allowing users to utilize the system in waves because they understand there are issues and rough edges to the process correct?

Yes of course, providing troubleshooting information in a support ticket is a crazy way to go, what could I possibly have been thinking. Stupid Cloudflare developers are stupid and only by calling them out as stupid can we possibly hope that they would take customer feedback to improve the product. :roll_eyes:

-OG


#11

No, he said he submitted one, that doesn’t make it any less irrelevant to the type of problem their system is having. Their eventual deduction was that the system has difficulty transferring domains that have certain extra services tacked on, that has zero to do with what was happening in his browser, it is an entirely different category of problem. EDIT: Okay, Sam says below that they want the HAR files, fair enough.

Yup. This is more than “rough edges” however. I am saying that some of the basic presumptions they made are wrong, but that is something they are highly unlikely to backtrack on unless enough users express the problems that those poor design choices are causing them.

Just to be clear, I am not saying that that API-driven design is not technologically admirable, or that it does not align with the long-term vision of Cloudflare, or that it won’t make a terrific article for the Cloudflare blog, explaining how they used Workers etc. It may be all those things.

Unfortunately, it also utterly fails to perform the job of transferring in domains, or even making it easy for users to indicate which domains they want to transfer. Iterative design is all very well, but determined users are now wasting ridiculous amounts of time working around basic UI problems that really should have been obvious before the first line of code was written.

I never said anyone was stupid, although I am wondering about the brainpower behind your apparent belief that forum posts are somehow not customer feedback.

What my approach recognizes is that everyone is naturally protective of their creative output and, as such, it takes a certain weight of accumulated user experiences, expressed publicly - not tentative support tickets each disappearing into their own silo - to gather momentum and make it obvious to the designers that there are significant problems.

Individual support tickets are going to do nothing to address the root problem that they have come up with a horrifically over-engineered solution to set of problems that have already been comprehensively solved using simple forms, as evidenced by the entire domain registration industry for over a quarter of a century.

I really want Cloudflare to be a credible alternative to my existing registrar, that is why I am bothering to engage with this process, but I am exasperated by the lack of long-established domain registration mainstays such as sorting by expiry date, or not having to manually de-select 249 domains every time I want to transfer one, and I hate that I have had to spend this evening removing hundreds of sites from Cloudflare so that I can even see my close-to-expiry domains on the list.


#12

Hi everyone,

This is Sam from the Registrar team. Thanks for posting your feedback and questions. We do read it, both here and in the support tickets, and are working to improve the system.

1) HAR Files
HAR files, submitted through the support queue, do provide a wealth of data that allows us to track down individual problems. Submitting those does allow us to do deeper investigations and gives our team the details they need to identify what went wrong. Without those, we only have half the picture, so we do appreciate and need those as inputs.

2) Retry failures
In addition to the issue with dedicated certificates, we’re finding that one source of these retry failures traces back to payment card provider rate limits. Each domain is billed as a unique item right now. It appears that some card providers limit the amount of unique transactions in such a short timeframe (both in general and from a specific provider). We’re working to address that now. In the meantime, if you have already completed a number of transfers, and can hold a few hours or a day and retry a single transfer, that would help us gather more signal about the issue.

Thanks again for being part of registrar early access.

Sam


#13

I am finding that the problem seems to apply to certain domains, regardless of whether I try to transfer them as a group or individually. I now have a stubborn collection of around 20 domains that won’t transfer even when certain more recently-added domains sail through.

Also, my card provider - German online bank N26 - give me an immediate notification for every payment and every failed payment. These stubborn domains are not getting that far, while others in the same batches are successfully paid.

I have a hunch that the stubborn domains may somehow have been blacklisted within the system. Just to be clear, all these domains have the same registrar status and contact details, there is no reason why some should be okay while others are not.


#14

Why not just display the error message, however raw, relating to the failure?

I mean, the system must be generating some sort of message or error, you could output that the page, along with the platitudinous text you are already displaying. Seeing a specific error, even if they don’t understand it, would make users feel at least a bit less bewildered.


#15

I think you made sense. I also think that the error that the domain name cannot be transferred has nothing to do with the browser. But the system’s prompts are too simple, so we can’t judge the source of the problem.

Since cloudflare’s work order submission process has become cumbersome, there are many problems that we have to post here, expecting them to see the problem quickly.


#16

I am as confused as you, why some domain names can be successfully transferred, and some have failed to transfer?


#17

I agree, although I can think of one instance when this system gave me a very helpful error message: a transfer failed because I had given the wrong expiry date for my payment card. Seeing that error message allowed me to fix the problem and try again within minutes, this time successfully.


#18

@SamRhea Just a quick follow-up on the theory about it being a payments problem, here is the result of an attempt to transfer 22 domains: one new addition and 21 “stubborn” domains. Only the new addition went through. This suggests to me that, in my case anyway, the problem is not too many transactions in quick succession.

I will give it a rest now and try again tomorrow.


#19

I use PapPal to pay, but I also face this wrong question.


#20

Have you solved this problem? Please respond to me