Mailed stopped working

I have setup cloudflare free plan for my website. I activated SSL and https for my domain.

After I activated https, mails from my website are not going, nor mails from my contact us form are being sent to desired email address.

As soon as i switched “off” https mail sending starts working.

Can someone guide why so ?

May I know how do you turn “on” or “off” HTTPS?

Did you see any error message?

It just shows “internal error”

I do https “on” and “off” from here

May I know exactly what settings you used under “Edge Certificates” tab?

I switched on https and rewrite https.

I sounds like you’re using Flexible SSL mode, which quite often creates loading problems on websites.

Yes, it is flexible SSL, and https is ON, what you suggest here to do.

Thanks for guiding in advance…

Hey, this is pain when email not working :-(. It’s hard to debug because everyone has their own unique setup. Let’s take a step back to re-structure your problem.

  1. Mail from your website/contact us not going: How do you send out email? do you run send mail on your server? Or do you us a third party service to handle email sending? Or is it a form that somoeone fill it to submit email? Can we have a link to your website so we can look and see?
1 Like

Hi, thanks for replying. I am using Mailjet to trigger mails from my website. You can visit my website www.waybackcopy.com to check the mail functionality.

The mails were working when https was not active. But stopped now after I activated https on my domain from cloudflare.

Pls guide.

Facing the same issue I am not receiving any kind of mails of my website https://royaltylashbar.com/… Now what should I do?

Anyone here to guide us pls…

Alright, May I know if you have your MX records in DNS. Go to your Cloudflare login and click on the DNS tab. You will find an MX record there if you had them before. The thing is that MX records aren’t proxied through Cloudflare. So an easy solution would be to search the DNS record for your mail. It will be something like mail.yourwebsite.com
Go to this record and edit it to DNS only. I think it will work, lemme know if it does.

Here is my setup

go daddy.com has the domain and I am hosting it on their economy cPanel hosting.

After troubleshooting the issues with my mail I discovered that if I prepended the mail in the Cloudflare DNS tab like so

I also changed the A record that is named mail in the DNS Tab to Disable Proxy status so that is is set to DNS only

Finally, when setting up the email in the Mail app in iOS and macOS, I put the incoming and outgoing mail servers to both be mail.mydomain.com instead of what I had previously which was mydomain.com

The previous way of setting up my mail via mydomain.com was recommended for security by the cPanel mail setup guide and it worked previously, but I could not get it to authenticate properly with Cloudflare

Hello,

  1. Change your mail CNAME record to an A record and point it to the same IP address, leaving the proxy icon at :grey:.

https://support.cloudflare.com/hc/en-us/articles/200168876-My-email-or-mail-stopped-working-What-should-I-do-

  1. A record - domain.tld - web server ip - orange cloud
    A record - mail - mail server ip - grey cloud
    CNAME record - www - alias of domain.tld - orange cloud
    MX record - mail.domain.tld

  1. If your form is trying to send email using domain.com it won’t work because that is Cloudflare’s IP address which does not have your mail server. You may need to specify mail.domain.com in your form which does point to your mail server’s IP address.

You can ignore the warning about a record exposing your origin server’s IP for things like this IF you’re not bothered about people knowing your servers’s actual IP.

I recommend checking your MX records because your post makes it sound like domain.com is set as the MX which won’t work because that’s Cloudflare’s IP. You’ll need to change your MX records to point to your actual mail server’s IP address.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.