Mailchimp syncing blocked

Hi there,

I’m struggling to make my Mailchimp synchronisation work in Woocommerce, since i made it host by Cloudflare. It was working before.
I figured out that the Mailchimp sync was stuck on “in wait” state in Woocommerce scheduled tasks.
I was able to execute all these tasks manually, and so the sync completed.
Then I tried to start syncing again, and of course it was not working, and executing manually each task to sync is not a solution.

So, I paused Cloudflare and the sync started so I understood the problem came from Cloudflare.
I disabled the Cloudflare cache at first (with Development Mode) but it didn’t start the sync…

Finally i found that the CNAME “www” record in my Cloudflare DNS should not be “Proxied” because it’s blocking the sync.
I turned it to “DNS” only, but it exposes my ip address so it may not be the best solution. I wonder if i should enter my server IP in place of my domain in this record.
I asked Mailchimp at first, and they told me to reach out to your support.

I hope someones can help!


That’s not a typical solution. If Cloudflare is blocking traffic, it should show up in the Firewall Event Log.

I can’t see anything with Mailchimp in Cloudflare firewall. I should probably turn off the firewall and test the sync again but i can’t see such feature :face_with_raised_eyebrow:

You can try Firewall → Settings → Security: Essentially Off

I did, but solved nothing.
Also i don’t see any errors in Mailchimp logs. I hope any one here can tell me why a www cname record can block Mailchimp :frowning:

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.