Mailchimp Domain verification issue

I’m trying to verify my domain using Mailchimp. I had it verified but since I activated Cloudflare I opted to have it reverified. I’ve hit a snag. I can verify it using Mailchimp’s Entri process. I have the correct CNAME and TXTs already listed and they are verified using the Entri process but I still have an issue with the verification of my domain.

Set the Proxy status for the CNAME to Unproxied (:grey:) / DNS-only.

If you still have issues after the above suggestion, - please share:

  1. What domain?

  2. What record(s) did Mailchimp ask you to change?

  3. How exactly do these record(s) look in your Cloudflare Dashboard now?

they are set to DNS only. This is what I see via Mailchimp’s Entri to Cloudflare. These are correctly set up.

These DNS record(s) are already what the public sees, so I can confirm they are set to Unproxied (:grey:) / DNS-only.

However, for the _dmarc record, you do actually have three (3) records that are coming out:

  1. v=DMARC1; p=none;

  2. v=DMARC1;p=reject;sp=reject;adkim=s;aspf=s;pct=100;fo=0;rf=afrf;ri=86400; rua=mailto:[email protected];

  3. v=DMARC1;p=none;

You can only have one.

I would therefore delete #1 and #3, even though they are an exact match, to what Mailchimp asks for.

It makes absolutely no sense that Mailchimp is asking you to run a “none” policy, if they are doing their things properly, in regards to the email authentication you are trying to set up.

A “none” policy will simply be an open door, that will allow everyone on the Internet to be spoofing messages, so they appear to be from your domain name.

1 Like

The issue was resolved with the help of Mailchimp support we found out it was a DMARC from Cloudflare that was blocking the verification.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.