Mail server unable to ping alter configure Cloudflare

Hi,
I have added a domain to cloud flare http service is working fine but my mail server is unable to ping it’s already more then 48hr still unable to ping it. I have other 3 domain that is working fine with mail server. I have checked the DNS setting with other 3 domain and its same but the 4th domain unable to ping

In short, does it mean you have got an A mail record :grey: (DNS-only) pointed to the IP address of your e-mail provider and the MX record pointed to this unproxied mail hostname?

  • or maybe different if using a CNAME setup or some 3rd-party e-mail provider …

But, how about your e-mail client/reader (MS Outlook, Apple Mail, Gmail, Mozilla Thunderbird …), is the sending/receiving server set to that mail (:grey: DNS-only) hostname or rather using domain.com (proxied :orange:)?

Email undeliverable when using Cloudflare

What is the result for executing a ping command?
What did you ping so far?

In the meantime, you could try to flush the dns for yourdomain.com using below tools for the neededtype of the DNS record (selected from the dropdown menu):

To check DNS propagation, use online tools like:


I have added MX and A record for my domain

May I ask when you added them? Since before, or now after my posting? (in case due to some later DNS propagation)

Looks to be good configured as far as I see.

Furthermore, I also get while pinging A mail record:

Request timed out.
Request timed out.
Request timed out.
Request timed out.

Not actually related, but may I just ask in your cPanel interface, Zone Editor → tonggarden.co.id, does the A mail exist?, or rather a CNAME mail?
Also, is the MX record pointed to tonggarden.co.id or mail.tonggarden.co.id in the cPanel?

I see the needed ports are open so far 25, 110, 143, 465, 993, 995.

I got 15 seconds of timeout.

May I ask, have you tried contacting your email hosting provider regarding this issue?
Also, seems like mail.tonggarden.co.id does not support TLS - just to note.

webserver.tonggarden.co.id

Seems like in the SSL certificate you have contains mail.tonggarden.co.id so far with other subdomains as needed.

rDNS record is different (also PTR) → Amazon compute one.

Are you running some Firewall maybe which limits/restricts ICMP traffic to your mail.tonggarden.co.id hostname?

Despite the fact of not being able to ping it, but does your e-mail work or not?


Uploading: 03.PNG…
Email is not working can receive but unable to send out

1 Like

Right, that’s where I got timeout of 15 seconds on SMTP when testing out.

May I just ask, does your Webmail work good or also some issues using it?

its same receiver does not receive it but no bounce error to sender

What just come across my mind, if it’s Amazon compute, is there some inbound/outbound firewall configured?

Or maybe you cannot use amazon compute somehow for sending e-mails as a measure for protection against spam?

Meaning, users on Amazon should use Amazon SES service?

I am not familiar with it, if so.

But, if you say it’s working fine with other 3 domains, just this one is having the issue …

Have you tried using telnet to port 25?

thank you let me check on it . I have change the mail server ip to another server hosted in some hosting provider it is working well

1 Like