Mail Server CNAME doesn't work after moving DNS to CloudFlare

My site blocked is hosted by Bluehost and they have my mail server set to blocked '. In order to simplify mail client configuration there is a CNAME for blocked pointed to blocked . I have found that since I moved my DNS to Cloudflare blocked ’ still works as a mail server name but blocked doesn’t. I tried pointing the mail CNAME to blocked ) but this made no difference.

Thanks in advance for anyone’s help on this.

I couldn’t figure out how to put an address in my post so I replaced each one with the word blocked.

Welcome to the Cloudflare Community. :logodrop:

You can mention domain names and hostnames by using the </> Preformatted text option.

This Community #tutorial should cover the answers to all your questions.

To be clear email is still working, I can’t use a subdomain when configuring a mail client, instead, I have to use the hostname of the mail server from Bluehost hosting.

Can you explain in detail what names you are using, which record types they use, what you expect to have happen and what is actually happening, so that we can offer better and more specific suggestions?

Let me try this way:

my subdomain is mail_dot_mydomain_dot_com. my hosting company mail server is hostname_dot_bluehost_dot_com. Until I changed my DNS to Cloudflare I was using my subdomain but I could use the mail server hostname interchangeably as my mail server name when setting up a client. Now the only thing that works is the mail server hostname. The subdomain is a CNAME record that was brought over from Bluehost when I added my domain to my Cloudflare account I assume.

Check your CNAME record in Cloudflare. If it is set to :orange: Proxied try changing it to :grey: DNS Only.


Thank you that worked!


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.