Mail sent as spam when DNS proxy activated for domain

Hello !
I have my own server and my nameserver are in Cloudfare
I have @ and CNAME “www” and A : “mail” as proxy in Cloudfare DNS management
I have SPF, DKIM and DMARC : PASS all 3 when i sent mails
When i OFF proxy for root ( @ ) to my IP adresse where the SMTP is deployed too i can send my mail 100% normal they arent sent in SPAM, they get recevied and marked as important
When i ON Cloudfare proxy for my domain, my mails are sent but marked as SPAM
In both cases i got SPF, DKIM and DMARC marked as PASS
In my server, i have Postfix, smtpd SLL for child domain mail.mydomaie dot com
same thing for Dovecot
I’d love to know how to fix it?
Thank you

You could post the domain name so that others can check the configuration.

I think the issue may be that the mapping ip ↔ domain ↔ ip (i.e. so-called " Forward-confirmed reverse DNS") fails if the mapping domain → ip is proxied by Cloudflare.

Hey there!
i disabled proxy ONLY for A : mail @ root and my mails are sent 100% normal
@bernardo.reino yes i think there is the problem, because when i log to my SMTP and my mail.hostname is proxied by CF then i cant even get synchronized, so no sent no receive, i just noticed it today after some try, so the problem is when i log to SMTP => try to get connection from mail.hostname ( IP SERVER ) => its PROXIED by CF => IP CF sent to my SMTP and there im stuck, no correct answer AUTH for that IP
How we can outpass it and still get mail@hostname proxy ON ?
The only way i found it is to disabled it only for MAIL@hostname

You can only proxy HTTP/HTTPS connections. The following Community #tutorial is a good starting point.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.