Mail record is not resolving - DNS Config error

Hi there,

This is my first post in this community. We are having some problem with the mail record not resolving, and we are not sure why.

We recently repointed our servers with Cloudflare and all of a sudden users cannot send or receive emails.They get this message when they attempt to send emails:

"DNS Error: 1006593 DNS type ‘mx’ lookup of lgtag.com responded with code NOERROR 1006593 DNS type ‘aaaa’ lookup of mail.lgtag.com. responded with code NXDOMAIN 1006593 DNS type ‘a’ lookup of mail.lgtag.com. responded with code NXDOMAIN

Our domain’s DNS is managed through Cloudflare

➜ ~ host -t ns lgtag.com
lgtag.com name server mary.ns.cloudflare.com.
lgtag.com name server matt.ns.cloudflare.com.

The mail.lgtag.com is not resolving correctly still.

➜ ~ host -t a mail.lgtag.com
Host mail.lgtag.com not found: 3(NXDOMAIN)

Please see attached image with Cloudflare DNS settings. Any help on this will be appreciated.

Well, as evident from your screenshot as well you do not have an A record for mail. You will need to set that up too, otherwise your MX record is pointing nowhere.

Hey Sandro, thank you for your response. Feeling a bit out of depth here. How do I do that?

1 Like

Will this do the trick? Cheers

It should though you shouldnt proxy it.

Wicked, changed now to just DNS only.

I guess this will need propagation to take affect?

Cheers

It will as it basically changed the IP from proxy to actual address.

1 Like

Thank you for pointing me to the tutorial and your guidance on this. Have a great day :slight_smile: