Mail not responding

Hi
New to Cloudflare
I set up a free account and did the DNS name swap as they stated in the settings.
Since then my webmail from my server is not connecting at all.
Not sure why it is not connecting. I have an SSL certificate on my site for the site and webmail.

Any help would be gratefully received.

Thanks

Rob

Have a look at this:

At a guess, sounds like the hostname that it connects to is set to :orange:, it should be :grey: for any hostname that handles non web traffic, i.e. mail.


This is how it is set at present

Rob

For starters, remove the two papaki.gr nameservers you still have set for your domain at your registrar.

Then, your mail setup looks all right. Which error do you actually get? Post screenshots.

1 Like

I have removed the two Papaki nameservers. This is the error I was getting.

And which is “this SMTP server”? Post a screenshot of where you configured that.

It’s the one that is listed in the records above: robsnow.eu

That one is still proxied and gets us back to the initial response of @domjh.

1 Like

Well everything that is mentioned in that tutorial from @domjh is correct on my settings. But I still get the errors. The SMTP is using TLS/SSL can that be an issue.
Sorry for all the questions, I’m new at this.

Well, not really. The record you specified is still proxied. You need to unproxy that.

Can you explain, proxied and unproxying? I am new to this Cloudflare service.

Anything with :orange: won’t proxy mail. If you’re trying to use the hostname ‘robsnow.eu’ for SMTP or POP/IMAP, it’s not going to work because it’s set to :orange:. Only a :grey: hostname will be reachable for mail services.

1 Like

OK, I have switched them all to :grey: now, so will let that populate and see if it resolves the issue.
Thanks for now.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.