Mail managed through Cloudflare marked as spam in Gmail


I have a varius domains registered on fastcomet, and I setup gmail (free, no g-suite), to send and receive the mails. I have the same configurations for all my domain, and different hosting provider, but only for one, specific domain, almost all mail (sent or received) as marked as spam.

My actual configuration is:

MX mydomainDOTcom server priority 10
TXT mydomainDOTcom “v=spf1 a:5817.submission.antispamcloudDOTcom a:release.antispamcloudDOTcom -all”

Fastcomet support says all is OK, but the problem remains,
what is wrong?


Despite what some may say, your mail/spam rate does not have anything to do with who managed your DNS. E-Mail deliverability and reputation entirely depends on the domain it’s sending from and the IP addresses that are sending the email. Even if you moved away from Cloudflare, your e-mail reputation would not change.

Thanks for infos! But we not send spam, we are a small and boring company… and before this domain was registered on godaddy, managed thought Cloudflare, hosted on fastcomet, we never had this problem… what you suggest to do?

Best thing to do is to keep sending “good” emails. If Gmail and the other providers no longer see spam for long periods (multiple months) the spam reputation for your domain will generally die down and reset.

How long exactly it takes to reset, and how emails change your reputation is a trade secret so you probably will never get a concrete answer on how to get your messages back into the inbox.

I would recommend also setting up DKIM at your email provider, as this further authenticates outgoing mail as coming from your domain.

Thanks for reply!

I’ve done a test with mail-testerDOTcom and the result is 9.9, I have dkim and dmark, and never, never, never, sent spam. We send only tech infos to clients and delivery times, about civil construction machinery. But the problem remain.

This topic was automatically closed after 31 days. New replies are no longer allowed.