Mail.example.com not resolving

Mail.example.com not resolving, DNS & Network

A few days ago, I connected my client’s site to cloudflare mainly to encrypt their site with an ssl certificate.

Everything worked perfectly! I was amazed.

Now suddenly their not getting any email. mail. is not resolving to it’s destination IP. Or I should say it’s not resolving at all.

The strange thing is that I haven’t made any changes on the hosting side nor on cloudflare.

My current DNS records on cloud flare are as follows:

  • A example.com IP-Of-Website-Hosting-Server Auto Proxied
  • CNAME ftp example_dot_com Auto Proxied
  • CNAME www example_dot_com Auto Proxied
  • MX mail IP-Of-Mail-Server 10 4hr DNS only (This one I just added in hopes it would help)
  • TXT mail v=spf1 +mx +a +ip4:IP-Of-Mail-Server ~all Auto DNS only
  • TXT example_dot_com v=spf1 +mx +a +ip4:IP-Of-Mail-Server ~all Auto DNS only

Did I do something wrong on the cloudflare side? Or should be looking at the mail hosting side of thing?

FYI:
domain regstrar points to clouldflare.
cloudflare is supposed to point everything except for ftp and the website over to the hosting server

Everything was working until today and I don’t know what happened.

Any help will be greatly appreciated :slight_smile:

You didn’t post the domain name, so we can’t check. I can only suggest this:

Thank you! that was the solution. I fixed it just before I got your reply. But I ended up doing exactly what that article says to check for. Thanks again!

1 Like