Mail accounts are not proxied

Since I have transferred my DNS servers to cloudflare I could not get proper mail deliveries along with it I could not access my mail accounts through other devices.
Is there a problem with MX mail settings?

The target of your MX must be :grey:. Cloudflare does not proxy SMTP or other mail protocols.

Also, if you are using “a” as part of your SPF record this will need to be updated to ip4, as “a” will probably match a Cloudflare address, and not the actual address you are sending from.