macOS WARP registration 'missing', 'but is still around'

What is the name of the domain?

brandient.com

What is the error number?

N/A

What is the error message?

​​CF_REGISTRATION_MISSING

What is the issue you’re encountering

macOS WARP app cannot connect, throws “Registration Missing”, settings pannel unavailable, CLI cannot delete, create new, reauthenticate

What steps have you taken to resolve the issue?

— Deleted macOS WARP app and reinstalled both current stable and beta;
— Waited out the App Preferences → Account spinner and got “Error encountered. Please retry in some time.” and unavailable Account panel (spinner);
— tried CLI:
sudo warp-cli registration delete
Error: Missing registration. Try running: “warp-cli registration new”
sudo warp-cli registration new
Error: Old registration is still around. Try running: “warp-cli registration delete”
sudo warp-cli registration delete
Error: Missing registration. Try running: “warp-cli registration new”
… and so on;
— Tried deleting every Library item I could find related to Clouflare;
— Tried revoking access of the device, with no change in app behavior.

What are the steps to reproduce the issue?

Not sure. The other devices are working. The error occurred after the last app update.

Screenshot of the error

Hello there, do the steps for “CF_REGISTRATION_MISSING” on the doc bellow work for this case?

If not, could you try run the following commands via your terminal?

warp-cli delete

You will then need to register and enroll into the organization which can be done via the GUI or using these two commands below:

warp-cli register

warp-cli teams-enroll

Please provide the new WARP logs after completing these steps if you are still receiving these errors.

Hi, and thank you for the reply.

Unfortunately, the same infinite loop manifests:

% sudo warp-cli delete
Error: Missing registration. Try running: "warp-cli registration new"

% sudo warp-cli register new
Error: Old registration is still around. Try running: "warp-cli registration delete"

% sudo warp-cli delete
Error: Missing registration. Try running: "warp-cli registration new"

Kindly advise.