LunarPages CNAME Setup Produces Origin DNS Error 1016


#1

Forgive the long-winded question, but some background is necessary.

I activated full zone setup at Cloudflare partner LunarPages for two of my domains, one of which is an addon domain to the other, if that matters. That worked fine, but I wanted to see the origin IPs in the cPanel error and visitor logs rather than Couldflare’s proxy IPs, and I want to be able to ban IPs in .htaccess. For whatever reason, LunarPages will not install mod_cloudflare.

LunarPages suggested I switch to CNAME setup. After doing that, I get Error 1016 on all pages. Cloudflare diagnostics tell me to "add a verification TXT record to your authoritative DNS," but neither Cloudflare nor LunarPages seems to give me access to change DNS records.

I just transferred all my domains to Cloudflare as the registrar, if that could be part of the problem. The transfers were completed this morning.

These domains are on the Free Website plan.


#2

You should have the zone in full setup on Cloudflare, not partial if we are your registrar/DNS provider. Being in a CNAME setup won’t change anything regarding the origin IPs/ mod_cloudflare.


#3

Thank you, @cscharff. I’ll switch it back.

To ban origin IPs in .htaccess with the zone in full setup, I tried this, but it didn’t work:

SetEnvIf HTTP_CF_CONNECTING_IP (^123.123.123.123) bad_bot
SetEnvIf HTTP_CF_CONNECTING_IP (^456.456.456.456) bad_bot
<RequireAll>
Require all Granted
Require not env bad_bot
</RequireAll>

Am I doing it wrong? Should I start a new topic with this question?

I am able to get the origin IPs in php with no problem.


#4

Well, I switched back to full zone setup in LunarPages cPanel. All of my pages are still producing Error 1016. I can’t access e-mail or even ftp. Something is clearly broken.

I can’t help thinking this has to do with switching to Cloudflare as the registrar.

Strangely, I don’t see any registrar tools on Cloudflare, other than the ability to globally change WHOIS information.

I’m at a loss as to what to do next.


#5

#6

Thanks, @domjh. I had read that and all other publicly available information on this topic before posting. However, I did not find the answer to my question.

It seems that after transferring my domains to Cloudflare registrar, the nameservers are no longer set. Is that possible?


#7

What is the domain?


#8

@domjh
www.neighborhoodspecialists.com


#9

The nameservers appear to be correctly pointing to cloudflare, however you don’t seem to have an MX record for the domain, hence the mail not working.

Does your A record definitely point to the right place?

If you pause cloudflare (overview tab), does your site work correctly?


#10

@domjh
The site does not work when Cloudflare is paused:
www.neighborhoodspecialists.com’s server IP address could not be found.”

In Cloudflare dashboard, there is no A record.

In LunarPages cPanel, there are several records, including A, MX, and CNAME. Only one CNAME record has “Use Cloudflare” set to ON by default. Is that the issue? When I initially installed Cloudflare, LunarPages seemed to turn on the correct records by default.


#11

This means it is not a Cloudflare issue. Sounds like DNS.

You should probably copy these over to the DNS tab in Cloudflare to get the site working correctly.

From what I can tell, you are on a Full setup rather than a partner. This means you should add the records yourself - the ones you see at your host do not appear in CF.


#12

Yes, as @cscharff suggested above, I switched back to full setup from the LunarPages cPanel. I switched each of the records in cPanel to ON, and they now appear also in the Cloudflare dashboard. However, I am still getting the same errors.


#13

I may have spoken too soon. Seems lilke some parts of the site are starting to work again. Perhaps some sort of propagation issue, then?


#14

Sorry for the late reply! Time zone issue :joy:

Possibly on the site front, you still don’t appear to have an MX record for your root domain so mail won’t work.


#15

Oddly, everything does seem to be working now, including e-mail. Perhaps LunarPages does things differently than other hosts. There is a CNAME record for mail; that may be all they need.

I also had to enable “Use Cloudflare” for all records except mail, ftp, and localhost in cPanel, if that helps anyone. They were not enabled by default.

It really does seem to have been a propagation issue. Basingstoke, UK is the only holdout. :wink:

Now back to the original problem: how to block ips in .htaccess on a shared server that doesn’t have mod_cloudflare. But, I think it would be appropriate to post that question as a new topic.