Lost my sub domain after installing Cloufare

I have a main domain, then I made a sud domain and point it to the right place through the registrar
Then I added Cloudflare to my main domain and than my sub domain has diapered, can’t be found on searched and can’t access the dashboard.
I did add it to the DNS record using A, still no sub domain
Tried to use CNAME but Cloudflare said that it was not compatible with CNAME

I am pretty new to Cloudflare but medium-good tech savvy. :wink: I usually can figure out things, read all of the similar topics on the forum, but I am still lost with that one.
Any help is much appreciated, Thank you!

Is the record listed under the DNS records on Cloudflare? If not you have to add it, Adding DNS Records

@sandro, yes that is what I did first thing after I saw my site disappeared. Cloudflare won’t let me ad it as a CNAME so I add it as A name

Why wouldn’t let it add you a CNAME? Only thing in this case, there can’t be another record.

What were you trying to add exactly?

I get a red error message at the bottom of the page when I add it as a CNAME
Trying to add my sub domain
The site was there and functioning before I added Cloudflare to my main clodycates.com site

Which error? Remove all “cccswag” records and try to add it.

I did that already but will try again

DNS Validation Error (Code:1004) Content for CNAME record is invalid

That is what I get

That is pretty self-explanatory.

What is the content?

My sub domain cccswag.clodycates.com when I try to add it as a CNAME
Clouflare only let me add it to the DNS record as a A name and the site still doesn’t show up anywhere on the web

Can you post a screenshot of what you are trying to configure?

I could see my site and was building it just fine before I install Clouflare on my main clodycates.com and that what I get now

No, a screenshot of your DNS configuration.

You simply configure a CNAME record, name it whatever you want, and point it to wherever you want.

Here and it gives me the same error with or without the clodycates at the end

That is an IP address and you need an A record for that, not a CNAME record.

Yes, and that is what I did first, see first screenshot I sent you above, still no website to be found

First of all, a “Name” should only be the first part, “cccswag” (unless it’s the naked domain only). Now you have to figure out if it’s an “A” records with an IP address (my favorite), or a CNAME that points to a valid hostname that will accept that request.

Thank you @sdayman
I did try both ways, just the first part and the full name, same results. When I talk to my hosting they told me that my sub domain was an A name and that is the IP they give me.
I made my sub domain before installing Cloudflare. I haven’t done much on that site yet, would it be easier to just delete that sub domain from my website and start again from scratch?
Thank you

When I put Cloudflare in developer mode, the sub domain shows up on Firefox, but nothing on Brave or on Chrome. And that is the first time I enter it into Brave so it is not a cache problem

@sdayman, I reached my max post for new user so replying to your last post here:

Thank you @sdayman. Yes, that is what it is suppose to look like. So you are saying that all is good and patience is the solution, Yes?! :upside_down_face:
Well, thank you very much for that.
One more thing, I shared a screenshot of my DNS earlier on this thread, is it safe, should I take it off.
I am just starting with Cloudflare, so there is lots i’ve got to learn :wink:
Thanks again and have a great day!


This doesn’t surprise me, as Firefox is probably using Cloudflare’s DNS by default, and that DNS refreshes quickly for Cloudflare domains. Brave/Chrome are probably using your local DNS which probably hasn’t updated, and may take a day to do so.

If this is what it’s supposed to look like, then you’re just going to have to wait until your local DNS catches up.

1 Like