Lost access to my Cloudflare access application

Hi, I’ve been using CF Access for an application, but today I tried to log back in and I get “This account does not have access”. I tried again and it’s not even sending me any token to authenticate anymore.

Please help as this makes me not trust and even recommend Cloudflare Access to my clients as a reliable service and I should not get locked out of my platforms just because something happened in Cloudflare Access.

Yes, I’m using the correct email, and yes I this email is authorized for the Access application

Here’s the logs for the application:

It says “Access dened”, and when I click on View for my policy, I can see my email as an approved user for this application, so I got denied access even though I’m an approved user

“app_name”: “my_app”,
“user_email”: “[email protected]”,
“user_id”: “my-user-id”,
“ip_address”: “My-IP”,
“app_uid”: “my-app-id”,
“app_domain”: “my-domain”,
“app_type”: “self_hosted”,
“action”: “login”,
“connection”: “onetimepin”,
“allowed”: false,
“created_at”: “2022-06-17T01:10:58Z”,
“ray_id”: “Ray-id”,
“country”: “my-country”

What do your access logs say is the reason you got denied?