Longer loading after instalation of CloudFlare

Hi Everyone,

Just got started with CloudFlare, following all steps required (or I think so). However the loading time of my website increased between 50% and 100% as compared to what it was before CloudFlare. I cannot afford myself to keep the website as it is, and will probably have to return to the original name servers within 24hrs at latest. Unless you have any idea on how to resolve the issue.
Thanks in advance!

What’s the domain?

innwalking.com

It looks like WordPress is handling the redirects, which doubles the response time. As it is, just a simple redirect is taking three seconds for your server to send to Cloudflare. And then another three seconds to send the actual page to Cloudflare.

  1. Make sure “Always Use HTTPS” is enabled in Cloudflare Dashboard’s SSL/TLS -> Edge Certificates section.
  2. Your main page is pretty static and doesn’t change for logged in visitors. You can add a Page Rule to match https://www.innwalking.com/ and add a Cache setting for “Cache Everything” and “Edge Cache TTL” of however long you’d like, depending on how often you update the front page.

If you want your site to be faster, you’re going to have to optimize it. It’s ~125 requests (not horrible, but not good), but 11 Megs of data, which is excessive. The images are beautiful, but are twice as much data as necessary. Many of your thumbnails are four times larger than they need to be.

A good Page Caching plugin should also help. I like WP Fastest Cache because it’s free and easy to setup, with good results.

As I browse the site, I don’t see anything that requires user login. If you like how the Cache Everything rule above works out, post back. You expand that rule to cover the entire site.

1 Like

Thank you for taking the time to check and answer. I tried also a plugin for image optimization, which made the web page 4 MB (from 12 MB). The loading time however only reduced by 10%. I am not an IT guy though and will have to contact the right person to help further.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.