Lock pad appears and goes

Installation of Cloudflare SSL works OK for main domain but not for a subdomain. In the subdomain (wordpress site)
getwebhosting.planetmarkets.com the lock pad appears and then disappears in Google Chrome and Opera. The lock stays in Microsoft Edge browser and in Firefox it stays half and half, that is, Firefox says the site is not completely encrypted. This is what firefox shows
https://www.screencast.com/t/uiG88SVphw
I guess there is something in the (wordpress)website that is not allowing some browsers to load the ssl certificate. What could it be? Images? How can I correct this? On the other hand the SSL works perfectly for planetmarkets.com main domain and any website under it as in: https://planetmarkets.com/planetmarketshosting/WHMCS/index.php
I did install the Cloudflare plugin in Wordpress and tested all options in this tutorial
SSL/TLS not working on subdomain

Hi @robertolitovsky,

Firstly, thank you for checking out the tutorial before posting :slight_smile:. I will add this possibility to that list!

That looks like a mixed content issue to me.

Mixed content errors mean that your website is being loaded over HTTPS but some of the resources are being loaded over HTTP. To fix this you will need to edit your source code and change all resources to load over a relative path, or directly over HTTPS.

For example, if you load your images with a full URL:

<img src="http://example.com/image.jpg" />

You would want to change this to:

<img src="//example.com/image.jpg" />

By removing the http:, the browser will use whichever protocol the visitor is already using. An alternative option would be to enable the Automatic HTTPS Rewrites feature that can potentially fix these errors for you automatically. Do be aware that resources loaded by JavaScript or CSS will not be automatically rewritten and mixed content warnings will still appear.

See this Community Tip for further details

1 Like

6 posts were split to a new topic: MX Record Issue

Thanks for your answer. I’ve already enabled Automatic Https Rewrites and things are the same. So, looks like the only thing left is to remove the http: , problem is: it’s full of images!

I am not on desktop right now, so can’t check what exactly the issue is. Perhaps @sandro or one of the other MVPs can have a look and offer some suggestions.

You could always go with suggestion #5 of @domjh’s link.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.