Loader.io bot Trying to Load Test my site

I’m trying to load test my site using the loader.io free service and get repeated “This test was aborted because it reached the error threshold.” messages.

My host was able to identify the IP that the test was coming from using the loaderio verification txt file I uploaded to my server. I set up a rule in the firewall to allow that IP source address and also set up an IP access Rule for the IP that applies to all websites in the account set to allow, purged cache, and unfortunately I still get the same error.

I’ve looked in loader.io’s help docs, Cloudflare’s help docs, Google, etc., but can’t find any info on this.

I assume there are lots of people using Cloudflare and load testing… Unlike me, they probably know what they are doing though…

A copy of the results here: https://bit.ly/2TmHZBq
Any help would be appreciated, thanks!
-josh

This normally does have nothing to do with Cloudflare and the Error also was not shown by Cloudflare, therefore this normaly does not belong to here.

Right.
The “threshold” Error does arise when to many errors (not specified which one) occur.
For example if you set under Advanced settings the Error threshold to “10%” then the test will be aborted automatically as soon as 10% of all send requests results in errors.

For more details please read: Timeout & Error (%)
And if you get an Error, just check from who you get this error from, there you should go to resolve him.

For more details like “what error occurred” please ask the guys from loader.io. But as you are using them as a free service please do not expect too much. Support should be paid, that’s why most companies do not offer it for free.

The Error category even got shown:


All 4XX or 5XX Errors. Chances are that they get blocked/firewalled by Cloudflare, so they can not “DDoS” you.
Just turn the Firewall to “Essentially off” and try again

Thanks for your response.
My host didn’t think the errors stemmed from them and thought it probably a Cloudflare firewall bot filter.
When I change the threshold to 90% and timeout to 60 sec. I still get the error https://bit.ly/3wFzIab

I’ll see if I can track down where the error came from in more detail.

Simply set Cloudflare to “Developer Mode” and try again. It this time Cloudflare will not do anything to your site, but just solely proxying it with bypassing ALL its functions.

No luck yet. Cloudflare in Development Mode and retested with setting the threshold for 50% and the timeout for 90 seconds.
https://bit.ly/2Tpk98h

If you really are in Developer Mode, then this proves that it is not related to Cloudflare.
Then just thje support of loader.io can help you as for further debugging exact errorlogs/error codes are needed.

Okay, I sent a message to loader.io and I’ll update the ticket with my host again to see if there is anything they are missing.
Thanks for you help!

I’ve run LoaderIO tests through my Cloudflare account with much higher numbers. Your numbers are…paltry.
Screen Shot 2021-05-26 at 2.06.15 PM

Does anything show up in Firewall Event Logs?

1 Like

…possibly
I’m not sure exactly what I’m reading here though.

It states that these requests has been challenged with a “JS Challenge”.
Whitelist the user agent or turn off firewall for these tests.

But activating Developer Mode should actually be enough AFAIK.

I don’t think Developer Mode will bypass the Firewall. At least, I hope not. But I’d make an “Allow” rule for a User Agent that contains ‘loader’

1 Like

I tried setting up a couple of different rules and tested but still had the same results… with Development Mode still on. https://bit.ly/3ujTSoB



Screen Shot 2021-05-26 at  2.28 PM

I guess if I read more closely, I would have seen that it’s been blocked by Bot Fight Mode. You’ll have to turn that off. On the other hand…yay! It does what it’s supposed to do.

2 Likes

Bingo!
Configure Super Bot Fight Mode > Definitely automated > Set to Allow
https://bit.ly/3fPmtwC (Cloudflare set to Dev mode)
Now I can see how poorly my site is doing ;-/

https://bit.ly/3g3eCMj ( Cloudflare Dev mode off)

Thank you one and all!
-josh

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.