Load Balancing Custom Rule Overrides not working

Hello,

I have an issue with the custom rules for load balancing and I’d really appreciate it if someone can help. The simple test expression I use for the custom rule works fine with the “Respond with fixed response” option, but doesn’t work with the “Override” one.
My load balancing setup is the following: two pools with a server each, a health monitor for each of them (default settings), traffic steering set to “Geo steering”, I have assigned all geo regions to the respective pool. This setup is ok - geo steering works as expected.
I am trying to make a custom rule so that specific url requests containing a string are ALWAYS directed to the same pool, overriding the geo steering setting. So I use the expression (http.request.uri.query contains “xxxxxxxxx=1”), I select “Override”, in “Choose Override” I select “Origin Pools” and here I select the pool which should always be used when the expression is matched. I have tried adding a second override with the “Terminates” option after the “Origin Pools” override but it doesn’t make any difference. I save the custom rule, then I save the whole load balancer too. “Session affinity” is set to Off. For some reason the custom rule doesn’t have any effect - the load balancer is still following the geo steering policy, disregarding the custom rule override.

Do you have any idea what I am doing wrong? Help would be greatly appreciated, thank you!

Regards

I can you help you out with the following ,

But i did not got what exactly you are telling .

Neeraj0001, what I am trying to achieve is basically the “Example configuration” given here, at the bottom of the page:
https://developers.cloudflare.com/load-balancing/additional-options/load-balancing-rules/create-rules
The load balancing setup I have is given in the original post. Thank you.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.