Load Balancer: No webpage was found for the web address

What is the name of the domain?

https://925303814.xyz/

What is the error number?

404

What is the error message?

No webpage was found for the web address: https://925303814.xyz/ HTTP ERROR 404

What is the issue you’re encountering

Set up a load balancer

What steps have you taken to resolve the issue?

I entered the load balancer endpoint urls as shown in screenshot

What are the steps to reproduce the issue?

Go to https://925303814.xyz/

Screenshot of the error

Hi @photohero.ai,

I checked your site https://925303814.xyz and it seems that the tunnels are down as I am getting an Error 1033.

When you were receiving the 404 error, was it branded with the Cloudflare logo?

I will keep the tunnels online to troubleshoot until this issue is fixed.

@bujangnim

Helped in Discord, as slightly described in Load balancers · Cloudflare Zero Trust docs if you try to use Tunnels w/ Hostnames you need to be careful of the hostname routing. Either use catch-all or use the per endpoint host header overwrite in load balancer to overwrite to the public hostname you have set it up for. For example if you had tunnel.example.com as your public hostname and example.com as your load balancer hostname, you’d need to have your endpoint be the <tunnel-id>.cfargotunnel.com, same as the CNAME target for tunnel.example.com, and then use the host header rewrite for that pool endpoint to tunnel.example.com so the tunnel knows how to route it.

If you are using local tunnels you can define an ingress config for example.com but the remote tunnel behavior of auto attempting to create a dns record makes it more tricky with them. Catch-all & host header overwriting are options for both.

1 Like

Yep, and use separate pools for each endpoint in the load balancer setup

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.