Load balancer monitor keeps on detecting site as down


#1

We signed up for load balancing and set up a simple scheme with two backend servers. We first tried with a health check that would detect the closing HTML in the monitored URL. It would always detect the server as down, we them removed the string check and left a simple HTTP check, which is always reporting both of our servers as down too.

We thought we would have done something wrong, so we checked every value. There doesn’t seem to be much places where you can input a wrong value, as input is validated. Both of our HTTP servers are up and responding to users and our checks.


#2

Nothing in the logs, just found one hidden alt text stating “Response code mistmatch error”. What’s that soppossed to mean.


#3

If you’re having us check the response body, we only check the first few k of the body for the the content you’ve specified. So using /html it’s likely that wasn’t in the portion the monitor checked.


#4

A notice under the Response Body input box would be of great help for everybody.
If you check at the application level and you’re wise, you will want to check the closing HTML tag.

Nevertheless after removing the Response Body string check and leaving a plain 200 status code response as check, we still have the same issue. The monitor check returns “Response code mistmatch error” and the logs are empty.

You charged on advance, but a simple HTTP 200 check doesn’t work. How are we going to trust the load balancing service if we can’t get it to report a 200 HTTP status code.


#5

Try setting a request host header in your monitor to the name of your LB.


#6

Thank you, that did the trick.

I would expect the Host header to be automatically added, as 99,9% of internet HTTP servers use host based virtual servers. Who runs an HTTP server on the IP nowadays, even if you did, the Host header would not harm.

And, above all, at least don’t hide it in the “Advanced health check settings” as if it was some obscure “just for geeks” option.

Thanks!


#7

This topic was automatically closed after 14 days. New replies are no longer allowed.