Live version does not load, but host is working

  1. If I browse to our domain name, I get the cached version through cloudflare:

  2. If I Refresh to try to get the Live version, it fails. I get an error that Browser is OK, Cloudflare is OK, but host is not available.

  3. But host is “up”. But if I browse directly to my host’s “vanity url” it’s super fast and loads the current version:

Background & What I tried
4. This problem began a week or so ago. No DNS changes in the last 6 months.
5. Confirmed that my DNS Nameservers have NOT changed.*
6. Put CF in Developer mode (to disable caching temporarily). Same results.
7. I Disabled the new Always Online. Same results.
7. I have these Page Rules (which have not changed in at least 6 months. I tried disabling those and got same results (cached version)

Hi @mranalogy ,

A 522 error typically happens when Cloudflare requests to the origin (your webserver) get blocked. Review the suggestions in this Community Tip for troubleshooting ideas.

1 Like

Ok, so looks like this IP address MIGHT be being blocked from accessing our hosting, right?
209.17… *underlined in red.

NetworkSolutions has whitelisted Cloudflare’s IP ranges.
Will take 4-24 h to propogate. But things already seem MUCH improved.

1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.