Live streaming problems

I’ve been trialling Cloudflare Stream for a few weeks and having some problems with the webplayer for live streams. The inputs and outputs work fine, but the Cloudflare player often won’t work. Where can I get proper support for this and find out the reason why the player isn’t working? The help guides are next to useless and I need to know if I have some setting wrong somewhere, but there is no documentation I can find to help me. When it works it works well, when it doesn’t I am doing nothing different. Please help me, someone?

2 Likes

Can’t work out when it works and when it doesn’t. The input is fine (or so I think): Input Status

  • Ingress bitrate: 5.5 Mbit/s
  • Encoding video bitrate: 5.4 Mbit/s
  • Encoding audio bitrate: 125.0 kbit/s
  • FPS: 50
  • GOP:100 Frames / 2 Seconds

But the player either displays “Video not found”

I should also add that I am sending RTMP from a restream.io account which works perfectly everywhere else. It also works sometimes and sometimes it doesn’t. I need to rely on a solution - please someone point me in the right direction.

@clandsbert sorry for the frustration — this is an issue we’re aware of and actively working on improving. We’ve just deployed some changes that should help make this better. Would you mind trying again to see if you can still reproduce the issue?

Seeing this thread, it appears that live streaming video is not yet ready for production. Is that the case?

Thank you so much for working on this issue. I have the same ‘Video not found’ problem, trying to embed Cloudflare Live Stream on ghost.org site (using OBS software with Cloudflare RTMPS and Stream Player). OBS connects perfectly to Cloudflare and my data is like this:

Ingress bitrate: 10.8 Mbit/s
Encoding video bitrate: 9.8 Mbit/s
Encoding audio bitrate: 159.9 kbit/s
FPS: 30
GOP: 89.95 Frames / 2.9983 Seconds

I tried it again. And same issue. Its terrible having to explain to bereaved families that they can’t watch the live stream of their loved one’s funeral because there is a technical issue.

This is the link of the stream today. It lasted over and hour, but the missing video shows 1m31s
https://dash.cloudflare.com/b472a44398fcf3f02cd8fb43b5e189fd/stream/videos/fa79cec7a367757f40048ac7b00015ff
Even if there was some sort of status page that was updated that would be a start.

This is still broken - it works very occasionally. Please how can we get further support?

1 Like

(post deleted by author)

I’m having the same issue with Live Streaming. Everything is setup right and in Cloudflare, in fact it even shows the video stream as “live” in Cloudflare, but just it cannot play (not even in the Cloudflare player). It just spin and eventually fails. Somedays it works fine, and other its doesn’t work at all.

1 Like

Can you play the stream while using the m3u8 url? It would be the first step to see if it’s the stream or the player.

Now this is interesting. The most recent attempt just displays a black screen without audio and the loading circle is present. The same is for the m3u8 player I tested. The previous streams show video not found in Cloudflare and even then with the incorrect duration. (normally 1-2 mins instead of about an hour as it shoudl be). The same input is configured for a number of outputs - they work reliably 100% of the time so I think the incoming stream is fine.

1 Like

I am also going to try streaming direct from the encoder to see if there is any difference.

Is Cloudflare streaming ready for production? It sounds like the solution is not yet fully reliable and therefore should be avoided for production at this time. What do others here think?

You should try that. Also do a mtr test from the connection you are streaming from to live.cloudflare.com. If there is any packet loss it could get problematic.

I never used providers like restream, but Cloudflare has it’s own “Restream” function. Streaming with ffmpeg, OBS or a good hardware encoder the streams seem to be very stable. I streamed for days using RTMPS and the m3u8 in my own player (videojs).

It screams MVP but everything that is not labeled as beta seems stable enough to me.

I’m guessing MVP here means Minimum Viable Product? I tried streaming directly but it worked from restream the last two times I tried. Has it been fixed - I did have some correspondence with a Zaid from Cloudflare - and maybe they fixed it?

Also the Cloudflare restream solution works for me too, but it is not user friendly at all (especially for no technical people who I need to control which stream goes where - I can just about trust them to use restream.)

Yeah that’s what I meant.

We are having the same issue, paying $50 per month and none of our last month’s videos will play or download.