Live Stream from XSplit

Hi. I signed up for Stream, created a Live Input and made sure that Live Playback and Recording checkbox is checked. I’ve got my RTMPS URL and RTMPS Key put into an XSplit “Custom RTMP” Output with the RTMPS Key in as my Stream Key and rtmps:// into the RTMP URL. I try to start streaming and it restarts a couple times then fails.

I’m not sure what to do with the Live Input ID. I am able to stream to youtube and twitch no problem. Anything specific I need to do in XSplit to stream to CloudFlare?

After I saw this post yesterday, I gave streaming from Xsplit Broadcaster a shot as well and encountered the same issue. I didn’t come up with a solution, but did play around with various stream settings including the frame rate.

In my experiments, it looks like it’s successfully streaming for 10-15 seconds then it restarts. After several restarts, it quits altogether and gives the “too many restarts” error message. I haven’t had any problems streaming from OBS Live, which I consider less cable and reliable than Xsplit, but I don’t have any idea why it’s restarting either. I’m going to check to see if there’s some enhanced logging or something that might be useful.

We’ll take a look at this. Stream Live is in beta and one of our goals is to go over any issues third party clients may be having and solve them. We just solved an issue with the Larix Broadcaster app last week:

1 Like

Thank you for looking into this, I happened to see the Larix message earlier today. A few more data points for you, I tried a few suggestions from Xsplit’s support team, including changing the encoder, the bitrate, trying a setting that interleaved audio and video, and altering the key frame frequency from 4 up to 10 seconds as well as trying the same for the B frames. The only change I saw during these tests was that after the first restart, I got the error almost immediately.

Xsplit didn’t notice anything pecuiliar in my logs and seem to be eager to help resolve the issue. Perhaps contact them directly?

@sinful622 we did take a look. It appears that an extra slash in the input RTMP URL, not anything related to video encoding settings, might be the issue.

From the Stream dashboard:

In XSplit:

Notice that XSplit doesn’t have the extra slash after the word live in the RTMP URL.

We’re going to update the code in our end so that this kind of issue doesn’t matter going forward.

I’ll update in a few days when we make this code change. Thanks for helping improve Stream Live during the beta!

1 Like

Wow. Glad it was something that simple. Confirmed that xpslit is working now. Thanks!

1 Like

Mini update: Stream Live now works whether you have a extra slash there or not. Both ways to set it up now works. :slight_smile:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.