Links serve random pages

With cloudflare in developer mode, everything works fine.
With cloudflare turned on links serve random pages. The front page is (usually but not always) whatever page I edited last. Either all links return the same page, or they serve random pages. Refreshing does not help.
I’m on www.grendel.no, self-hosted wordpress site.
Any and all help and suggestions appreciated.
Thank you.

I am not familiar with this behaviour.

May I ask do the original links linking to some wrong domain or?
Is your website infected with some malware?

Could it be some issue due to redirection or rewrites like from HTTP to HTTPS (or vice versa), or even like between www and non-www (or vice versa)?

https://www.grendel.no/?page_id=497

  • broken Visual Builder / Editor

https://www.grendel.no/?page_id=373

These two links, work over HTTPS and www. I see both having separate, different content.

No redirection in between.
Tested with and without Adblock (just in case).
Google Ads not showing/loading.

Have you tried clearing your Web browser cache?

Possible ISSUE
Homepage - https://www.grendel.no/

The links here at the screenshot:
«Psykolog på Levanger». → https://www.grendel.no/psykolog-p-levanger/?swcfpc=1
om her. → https://www.grendel.no/big-5-testing/?swcfpc=1

Both linking to nowhere - or pointing back to homepage “as-is”.

?swcfpc=1 are you using WP Cloudflare Super Page Cache plugin for your WordPress?

cache-control: s-maxage=31536000, max-age=60, max-age=300
cf-cache-status: HIT
cf-edge-cache: cache,platform=wordpress
x-cache: HIT from www.grendel.no
x-mod-pagespeed: 1.13.35.2-0
x-wp-cf-super-cache: cache
x-wp-cf-super-cache-active: 1
x-wp-cf-super-cache-cache-control: s-maxage=31536000, max-age=60
x-wp-cf-super-cache-cookies-bypass: swfpc-feature-not-enabled

You also use APO for WordPress, correct?

If so, there seems to be some caching issues here as far as this is not an official Cloudflare plugin for WordPress.

Do you also have some custom-made Page Rules applied for your domain?

Suggestion for troubleshooting:

  1. Check if you have and disable Page Rules (which contain Cache Everything, if so)
  2. Disable the WP Cloudflare Super Page Cache
  3. Purge Cache at Cloudflare
  4. See if anything different
  5. Disable APO for WordPress temporarily
  6. Purge Cache at Cloudflare
  7. See if anything different
  8. Other than that, either some web server litespeed cache (from the hosting provider) here causing some issues too or we could troubleshoot further …

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.