LinkedIn Preview Tool Returning Error when Proxy Enabled

LinkedIn post inspector (and consequently link previews when attached to posts) return an error when Proxy is enabled in DNS.

returns “We encountered a server error while trying to inspect the URL”

When the proxy is disabled and set to “DNS only” the request works fine. Presume there is some BOT blocking going on.

Facebooks preview tool appears to work fine

Official Wordpress Cloudflare Plugin is configured with defaults.
Can you let me know how to fix for LinkedIn?

thanks

Hi there,

By default, Cloudflare will allow LinkedIn bot since is a trusted bot:


https://radar.cloudflare.com/traffic/verified-bots

You only need to make sure your super bot fight mode is set to allow Verified bots under Security > Bots:

If that’s done and the error persists, you might have one of your own custom WAF rules blocking it.
I suggest going to your firewall events under Security > Events and filter for
User agent + contains + linkedin and set the windows to 30mins/Live:


Now in a different window go to LinkedIn and try to trigger the issue and then go back to your firewall events.
You should be seeing an event, scroll down and expand it under Activity log and see which firewall component blocked it.
Then you only need to change the rule or create a condition to bypass it.

On an end note, I see that you still have the old managed rules (at least in the zone of yours I’m checking). It’s advisable to upgrade to the new managed rules as there is a performance gain and new signatures detection. (It could even be this blocking LinkedIn)
To upgrade, navigate to Security > WAF > Managed rules > Review configuration > check if everything is ok and press Deploy.

Take care.

1 Like

Hi - thanks for the reply. I’ve tried the recommended actions but without success, specifically

Setting Firewall events to look for user agent (contains) linkedin returns no results.
I have updated to the new managed rules, but get the same result from the LinkedIn post inspector and again no events flagged in the Security section

Disabling the proxy allows the inspector to retrieve data

Can you advise on any further suggestions?