<link rel="alternate" href="..." hreflang="vi" />, Cloudflare auto convert https://

, Cloudflare auto convert https:// to //, how to fix My website: https://modradar.com , i use CloudFlare. i have turn off auto convert http to https But Cloudflare auto convert all url of tag: Convert https:// to // . This is not good for google How i can fix that ?

I’m not quite sure what you are seeing, but redirects for your site are…

http://modradar.com/
https://modradar.com/
https://modradar.com/id/

https://cf.sjr.org.uk/tools/check?48711b2d7ebf4b2593889d9e0859ad4c#connection-server-http

What do you see?

ModRadar auto convert https://modradar… to //modradar
(in <link rel=“alternate” tag ^^)

These?

    <link rel="alternate" href="//modradar.com/vi/" hreflang="vi"/>
    <link rel="alternate" href="//modradar.com/en/" hreflang="en"/>
    <link rel="alternate" href="//modradar.com/id/" hreflang="id"/>
    <link rel="alternate" href="//modradar.com/" hreflang="x-default"/>

This is in the content not the headers so Cloudflare rules wouldn’t be doing this. You can check if it is a problem with minification by turning that off here…
https://dash.cloudflare.com/?to=/:account/:zone/speed/optimization/content

If you set the DNS record to “DNS only” instead of “Proxied” does the problem still exist?

i have auto redirect https://modradar.com homepage into https://modradar.com/LanguageCode/ but maybe Cloudflare cached homepage.
How for disabled ?