Leverage browser caching and specify a cache

Hi there. I just signed up few days ago with your service and I’m still testing it( with the free version in order to see if I can implement your service to cache all of my wordpress sites files(along with backblaze cdn).
So, on this site that I’m testing after I uploaded my files on a backblaze bucket everything works well and the pics are there. Except for two things:

-leverage browser caching
-Specify a cache validator

That’s the problem which google insights and other test sites are telling me to resolve.
Basically I want to make my site load faster by using your service but unfortunately it loads slower due to those two problems above.

Regarding the first problem(leverage browser caching) it seems it’s now set to 1 day and I need to set it to at least 1 week or more. Is there any way to do this from my Cloudflare free account? I tried with a htaccess code but didn’t worked even if hosting told me Mod_Expires service was available.

Are these two problems regarding to Cloudflare, cdn or hosting itself? thanks

Take a look at the Caching tab on your Cloudflare account and check the Browser Cache Expiration setting. That should fix browser caching on most resources:

As far as Specify a cache validator, that one bites me from time to time and I haven’t mastered that one yet.

thanks sdayman

I managed to resolve the first problem (leverage browser caching is set to 1 day and it should be at least 1 week or more)

It was based on Cloudflare page rules so I modified from “browser cache ttl” to more than 1 day(6 months) and that error is gone.

Now I still have that cache validator issue and I don’t know if is related to Cloudflare or my hosting. The thing is if I temp stop the Cloudflare for my site that error is gone. So, I guess is something to do with Cloudflare settings as well? But maybe it can be done from hosting.

I’ve thought cache validation could be handled in .htaccess, but I haven’t followed up on this. That warning seems to have disappeared from my sites, so I’m not sure if I’m the one who fixed it. Maybe this:

<IfModule mod_expires.c>
    ExpiresActive On
    ExpiresDefault "access plus 1 week"

it seems disabling “edge cache ttl” resolved the second problem :slight_smile: