LetsEncrypt works with my game but CF doesnt

I am hosting a WAMP website through which players connect to my game via http BUT the plan was to make it HTTPS.
And I failed to do it with CF many times however with Lets Encrypt it worked.
I have to renew lets encrypt every a while so I thought it would be better to get Cloudflare working as they have very long term certs.

How it worked with me via Lets encrypt:

  1. had to get ca_bundle.crt, certificate.crt and private.key from sslforfree.com but i believe other generators and offline scripts work as well.
  2. included all these files in WAMP and set them in httpd-ssl.conf file.

Now my issues with CF:

  1. I get .pem key and .pem files. dont know if its allowed but i changed them to .crt and .key extensions.
  2. CF doesnt give ca_bundle.crt file but they give:
    -origin_ca_rsa_root.pem
    -origin_ca_ecc_root.pem
    I changed them to .crt and included in WAMP folder. I included them both as CHAIN files e.g:
    SSLCertificateChainFile "{SRVROOT}/conf/key/origin_ca_rsa_root.crt"** **SSLCertificateChainFile "{SRVROOT}/conf/key/origin_ca_ecc_root.crt"
    but to be honest am not sure if ecc is a chain file.

am not sure if what is lacking is the CA_BUNDLE.crt file or im including origin_CA files in wrong place or something is wrong with my CF settings but something is going on

Any help appreciated!.PS theres no error when players connect to my game, it just doesnt find a referene to a in-game unity object. no such problem with Lets Encrypt.

Cloudflare is not a Lets Encrypt replacement. You will still need LE on your server anyhow.

what do you mean? i thought CF gives ssl

No, it does not respectively it only provides a certificate for its own proxies. You still need to secure your server. If you wanted to use Cloudflare only for SSL, then you can stay with your regular configuration as well.

This topic was automatically closed after 30 days. New replies are no longer allowed.