Lets Encrypt

“We are reaching out to inform you about an upcoming change that will impact the device compatibility of Let’s Encrypt certificates issued after May 15th, 2024. We are reaching out to you because we identified that you are currently using Let’s Encrypt certificates through Universal SSL, Advanced Certificate Manager, Custom Certificates, or SSL for SaaS. We recommend that you familiarize yourself with the Let’s Encrypt change and make any necessary adjustments ahead of time.”

I have no idea if this is applicable to me, and I don’t know what it means.

I am not a tech expert, so I don’t know what to do.

I tried to reach out to Cloudflare directly, but they seem to have closed their support ticket system and there doesn’t seem to be a way for me to contact them to ask them about my individual case.

Can anyone help?

If your site is proxied, then check if you have an edge certificate issued by Lets Encrypt (if you are not sure, put your site in here).

The best short description is here…

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.