LB Pool Monitor receives too man Health Check Requests

When the Pool Health Monitor interval is 60, we receive around 20 health check requests PER SECOND.

Because of this we now lowered the interval to 1000, but then we still receive ~1 health check request PER SECOND.

And because the interval is at 1000 now, and even though we still get ~1 health check request per second, the failover doesn’t seem to work (in timely manner) any longer.

Why are there so many health check requests sent?
How can we reduce this to one or just a handful every interval like 60 seconds?

Hi there,

curious what your health check region is set too under the pool settings? -

You can read about this here:

The more regions you have the more health checks you will have - so reducing the number of regions could be a way to reduce your health checks here.

Hope this helps!

It’s on “All Data Centers” and not configurable.

Typically, the ‘All Data Centers’ is only available for an Enterprise customer? - If I can confirm, are you a part of an account/organization that maybe you have limited role permissions that is not allowing you to edit this setting?

If your not an Enterprise customer - then this sounds very strange and may be require a support ticket to be raised in order to investigate the specifics of your configuration.

No we’re on the Pro plan. And on a second check it looks like the option can be changed, just the “All Data Centers” needs to be removed at first then it’s possible to select one/multiple regions.

This means the the huge amount of health checks results because all Cloudflare data centers send these?

What’s also weird is that after an interval change to 1000, all data centers seem to send their checks immediately and using the correct interval. Then over time the delay gets shorter until we receive ~1 health check per second. We can see this in the image:

I have worked with around 7 different cloud/hosting providers and never seen health checks implemented like this. Is there a reason for this?

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.