Latest WARP (May '22) on macos keeps disconnecting

I’ve been trying to get the WARP client working with Cloudflare ZeroTrust, but it starts to connect then immediately disconnects again, repeatedly.

MacOS client, Version 2022.5.227.0 (20220525.15)

I’m using a new M1 MacBook Pro and have very little other software installed (it’s new) with macOS Monterey (12.4)

The client logs show

2022-06-03T00:55:55.646Z  WARN main_loop: warp::warp_service: Tunnel connection experienced error error=Custom { kind: AddrNotAvailable, error: "Couldn't bind any UDP ports for DNS server" }
2022-06-03T00:55:55.649Z DEBUG main_loop: warp::warp_service: Entering main loop arm arm="conn_error"
2022-06-03T00:55:55.649Z ERROR main_loop: warp::warp_service: Connection error```

Which suggests it's having trouble.


On a hunch, however,  I removed it and installed the previous version (Version: 2022.4.114.0 (20220407.11)) and that appears to work fine. I can connect and things seem to work as I expect.

Is the latest version broken or am I doing something wrong?

Probably neither. That’s the version I’m running on my M1 MBP and iMac. So, definitely not a broken version, and you’re probably doing nothing out of the ordinary.

Are you saying you have Zero Trust set up in your account? If so, have you tried logging out of ZT in WARP?

I’ve tried without ZT, and just “1.1.1.1” and “1.1.1.1 with Warp” and it’s the same, it immediately disconnects and tries again and disconnects and tries again. with the UDP error in the log.

I’ve upgraded to 2022.5 and it breaks, downgrade to 2022.4 and it’s fine, in all cases.

I’m trying to evaluate this for use in a company, and I can’t expect everyone else to run very specific old versions of it, so I need to figure this out. But I’m stuck.

further digging shows it’s trying to bind to UDP port 53:

2022-06-06T20:23:49.717Z  WARN warp::warp: Unable to bind local TCP socket error=Os { code: 48, kind: AddrInUse, message: "Address already in use" } sockaddr=127.0.2.3:53

lsof shows this is being used:

 % sudo lsof -i4UDP:53
COMMAND   PID           USER   FD   TYPE             DEVICE SIZE/OFF NODE NAME
mDNSRespo 163 _mdnsresponder   16u  IPv4 0x6152e5efc9d391e5      0t0  UDP *:domain

mDNSResponder appears to be a normal part of OSX as far as I can tell.

I have the same thing showing up on my Intel MacBook Pro. I found a support article linked from the 2022.4.114.0 version that states a strict firewall will block the agent. I have checked out all that it wants to have unblocked and do not seem to be blocking any IP or port from it’s list. Yet when I try to move to a 2022.5.xxx version it will not connect.

If anyone finds this thread as they are having issues like this. I finally tracked my issue down to a laptop firewall that blocked all inbound, but allowed all outbound…only two settings on the firewall…pretty simple. Once this was shut off all worked as it should and the client came up. From the developers doc’s I am thinking ingress needs to be allowed at least on these IP’s:

WARP Ingress IP

These are the IP addresses that the WARP client will connect to. All traffic from your device to the Cloudflare edge will go through these IP addresses.

  • IPv4 Range: 162.159.193.0/24
  • IPv6 Range: 2606:4700:100::/48

It may be that you need all of the following four ports ingress allowed as well, but I didn’t test to figure this out as I am training the local firewall on the laptop for the zerotrust firewall in the cloud, so opening more up was a trade off.

WARP UDP Ports

WARP utilizes UDP for all of its communications. By default, the UDP Port required for WARP is: UDP 2408. WARP can fallback to: UDP 500, UDP 1701, or UDP 4500.

This was on the laptop. Interestingly enough, there is another firewall in my path that also blocks all inbound traffic (network based firewall). This block does not seem to effect the zerotrust client like the OS X firewall does. I am sure there is more detail to this for those that have time to track down the exact issue…but lifting the inbound block on OS X resolved the issue for us. Hopefully this helps someone out there if they are having this rather frustrating issue with the clients after 2022.4.114.

1 Like

Hi! Go to:

/Library/Preferences/SystemConfiguration/ with Finder and remove all files in that directory. Empty Trash and reboot.

Now WARP should work.