Large waiting time in the very beginning of loading website homepage

Hello! I’m fairly new to the community so I hope I’m posting this in the right place. I spent some time trying to find similar issues and solutions but didn’t find anything.

Up until yesterday my domain www.symboxium.com was loading really fast and everything in terms of optimizations caching etc was great. Today even though nothing was changed on my side it became extremely slow. I’ve managed to recover some of the speed but there is still one main bottleneck and it is in the very beginning of loading. 1.7seconds are spent in the very beginning waiting for a response from the site. I have attached the waterfall from gtmetrix. Is this normal?

I have already added a rule for caching everything and even though the overalls speed increased a tiny bit the waiting part did not! Does anyone know how to fix this?

Thank you in advance,

George

cf-cache-status says BYPASS, which isn’t normal. By default, it should be DYNAMIC. But you said you added a Cache Everything page rule, so it should say MISS (for first visit) or HIT (for cached visit). Can you post a picture of your Page Rules?

Hey, thank you for the fast response!

Here is a screenshot of the pagerules

I only changed that less than an hour ago, could it be propagation time that is causing the issue or something like that?

That’s the Edit screen for that one Page Rule. Can you post a picture of all the Page Rules?

Yeah I went in the edit mode to make sure everything is visible. I have no other page rules :sweat_smile: what am I missing?

Something on your server is telling Cloudflare to not cache that page. /past-boxes/ will cache and works great, so I don’t know what’s up with the home page.

I’m completely clueless so I don’t want to mess up anything! Could this be of any help?

Oh damn, that did the trick! I added the edge ttl 4hours as an extra setting in the pagerule and my first ping was a miss! After refreshing I got a hit! I have no clue what I just did but hey if it works it works!

Thank you so much for trying to help!

That doesn’t explain why one page behaves differently from the other. Setting Edge Cache TTL just overrides whatever killed caching at the server end.

Yes and it turns out it overrides even more, it doesn’t recognize that I’m the admin when I visit the page and it loads it as if I was a visitor so I cant edit it unless I go through wordpress… Do you have any suggestions/clue where else to look? Could it be bluehosts fault somehow?

Just wanted to note that your TTFB on the main page is incredibly slow. That is an issue with your host/setup. Your server is slow to respond and get the text/html file, it seems.

You are trying to fix that issue by using CF cache, which isn’t wrong, it’s just a different way to try to solve the problem. You may want to look more at your origin server setup and the cache settings on that end because that is the more likely source of your issue it seems.

I’m guessing the max-age may be worth looking at:

1 Like

Thank you so much! I have already tried contacting Bluehost support today many times but they seem to know less than I do and it is pretty frustrating. Finally they opened a ticket with their developpers and will get back to me so hopefully I will know more about their side soon!

I took that SS of the load time after opening the page and quickly refreshing to see if it would load fast or slow, it still had the issue and the max-age parameter will get honored at 0 to my understanding, so essentially, it won’t cache.

A little birdie told me that because the page sets a cookie, it won’t cache unless you force it…which means that’s probably not a good idea.

2 Likes

Where the ■■■■ is this cookie coming from remains my question though :sweat_smile: I’m completely lost guys, I try to fix 1 thing and 2 other things break :joy: I’ve spent countless hours today on bugs all over the place so I guess I’ll look at it again tomorrow with a fresh mind! Thank you so much both of you!

Well, it looks like the Cookie warning sets one :crazy_face:. Plus the the other ones that showed up in @dmcclure’s screenshot. Anything other than cfduid comes from your server/site.

As he suggested, the core issue is server performance. Anything else is a band-aid. Where Cloudflare assists is in caching all the static elements, and that should speed up overall load time. But if the server is painfully slow, you’ve lost before you even begin.

2 Likes

There are two distinct but unrelated issues at play here.

  1. A somewhat slower loading time of the document, which you mentioned originally.
  2. The main document not being cached.

As for #1, that is something that is happening on your server. You will need to get your server to respond faster, right now it is about two seconds.

As for #2, the main page is sending cookies and these prevent Cloudflare from caching the document. Yesterday you sent about four or five cookies, these you seem to have disabled at this point but you are still sending an “asp_transient_id” cookie.

The other issue is what you mentioned, that it does not recognise you being an administrator. This is because of the caching, so you cannot really cache in the first place. In this context the cookies will be irrelevant and your only issue will be that the site is relatively slow. It certainly could be faster, but to be honest it is not that slow. We had examples here on the forum, which really were slow :slight_smile:

If you want to speed up your site, that is something you can only do on your server and it would be probably best to take this to your developer as I presume your host will not be responsible for that either (unless you have a special agreement with them).

1 Like

Thank you so much for the thorough reply! “it would be probably best to take this to your developer” Sadly I am the developper for now and I have absolutely no experience in web dev but I also have no money to hire one :sweat_smile: :sweat_smile: Considering how little I knew/know I guess hearing that honestly it is not that slow compared to stuff you’ve seen is great!

In terms of 1) somehow the ttfb has dropped to 0.86s so I hope it stays there and it is not due to testing it when bluehost was not overloaded. I already contacted them about it and they suggest upgrading the plan if I want more speed but they have opened a ticket with their devs so they will get back to me if there is something more they can do.

In terms of 2) as you both explained it would be more of a bandaid rather than a fix so I won’t pursue it more for now. I have no clue where the asp_transient cookie comes from but I will look further into that!

Thank you so much everyone for the help and apologies for how little I understand and how little I helped you help me :joy: You’re the best!

1 Like

There are faster sites out there and there certainly is room for improvement, but the whole site loads in about two, three seconds, which still is perfectly acceptable. We had extreme examples here on the forum of twenty seconds upwards.

That is because it is cached right now. Once Cloudflare clears the cache - and assuming you still send cookies - it will be back to the earlier timings.

As I don’t know what plan you have I can’t say it with absolute certainty, but I somewhat doubt an upgrade would improve much. It simply seems the site is doing too much (or is not optimised enough) and simply takes the time it takes.

Probably some standard ASP cookie, you might want to clarify this on an ASP.NET related forum. However considering you cannot cache in this context in the first place, caching is not much of an option (and you should disable it, as you seem to have it enabled right now).

There are faster sites out there and there certainly is room for improvement, but the whole site loads in about two, three seconds, which still is perfectly acceptable. We had extreme examples here on the forum of twenty seconds upwards.
Since i'm not a developer my main goal was to reach a load time that doesn't annoy the user to the point he leaves before he sees anything. That is why the ttfb was a bit important because before I optimized the rest the page would literally be empty for 3-4 seconds as it loaded and I would have left if I was a customer facing that.
That is because it is cached right now. Once Cloudflare clears the cache - and assuming you still send cookies - it will be back to the earlier timings.
Well that sucks, thought god was being nice to me :joy: However I did purge the whole cloudflare cache earlier so that is a bit weird!
As I don’t know what plan you have I can’t say it with absolute certainty, but I somewhat doubt an upgrade would improve much. It simply seems the site is doing too much (or is not optimised enough) and simply takes the time it takes.
The cheapest one with shared hosting so it probably will get a bit better but I don't know if it is worth the money honestly. In terms of all around optimization I have done as much as I could and the page has >90% on gtmetrix and other graders so I honestly don't know what else I could mess with. I am using a template so maybe that is not that well optimized although it advertises itself as extremely well optimized. Or maybe it is doing too much but I don't see how since it is a pretty basic page compared to stuff i've seen.
Probably some standard ASP cookie, you might want to clarify this on an [ASP.NET](http://ASP.NET) related forum. However considering you cannot cache in this context in the first place, caching is not much of an option (and you should disable it, as you seem to have it enabled right now).
I will ask on one of their forums, thank you for that! And oopsies I forgot to clear the page rule, thank you for reminding me! :sweat_smile:

Once again, thanks for everything! :heart: