Large images stop download around the 5.2MB mark

Hello everyone. I’m getting a pretty weird problem with images. Basically, when I open an image through Cloudflare, it stops downloading at 5.2MB. When I do the same through my nginx server IP, it downloads completely. I’ve tried purging the entire cache, but the problem persists.

What am I missing here?

Nginx IP:
https://54.232.15.251/rails/active_storage/representations/proxy/eyJfcmFpbHMiOnsibWVzc2FnZSI6IkJBaHBBeDV6TFE9PSIsImV4cCI6bnVsbCwicHVyIjoiYmxvYl9pZCJ9fQ==--88341b19c080a23a0a3439c22294e2030dbf1f0a/eyJfcmFpbHMiOnsibWVzc2FnZSI6IkJBaDdDRG9MWm05eWJXRjBTU0lJY0c1bkJqb0dSVlE2RW5KbGMybDZaVjkwYjE5bWFYUmJCMmtDMEFkcEFyZ0xPZ3B6WVhabGNuc0hPZ3B6ZEhKcGNGUTZFR052YlhCeVpYTnphVzl1YVE0PSIsImV4cCI6bnVsbCwicHVyIjoidmFyaWF0aW9uIn19--65298e8af13a7e8ca38ac07942a34ee6f18f7a82/1%20endereço_preview.png

Cloudflare URL:

That one loads for me:

This is weird. It stops at 5MB for me and various users who complained. We are in South America, near the Sao Paulo data center. Would that make a difference?

If you notice my cf-ray, it shows LAX (my local Cloudflare datacenter). What does your cf-ray show?

GRU. That’s “Garulhos” a city near near São Paulo.

Out of curiosity I downloaded Thor browser and opened the link. I got the full image, and CF-RAY says AMS (I guess that’s Amsterdan?).

Does that mean that’s something wrong with Cloudflare itself?

(Dropbox links to get around the new user 1 image limit

GRU: Dropbox - Screen Shot 2021-12-17 at 21.26.54.png - Simplify your life

AMS: Dropbox - Screen Shot 2021-12-17 at 21.27.02.png - Simplify your life

Same. Loads up.

What’s the internet speed connection from your ISP?

But, approx. ~10MB image, 2000x3000?
I am afraid it should take some time to download and preview it:

Nevertheless, that’s a realy long one URL too (works, but just to consider if something needs to be served from your origin/server → Cloudflare → user).

May I ask where do you use so large image?

Even it’s png, shouldn’t it be smaller and optimized a bit for a web?

For feedback information, if helps, I am downloading it from cf-ray “BUD” (somehow, not exactly sure why it goes like that by my ISP since I am from Croatia).

It’s a 500mbits connection. Plus, I have no trouble viewing the image when using my load balancer’s IP, only cloudflare’s URL

This is generate by Rails Active Storage. We use it everywhere on our website, and plenty other apps use it, so It shouldn’t be related.

We use optimized versions in most of our app. The one you are seeing is the high quality version we allow our users to download and print.

Yeah it seems that only GRU is having problems.

300dpi and png? I am a bit surprised for the type of the usage it is.

I just ran it through CDN Performance Check | Uptrends and almost every location was ok. Except GRU at ~5MB, and AKL at ~3MB.

As this is reproducible, I suggest you open a ticket via email: support AT cloudflare DOT com

Post the ticket # here as soon as you get the autoreply. It’s entering the weekend, so they might not be able get to it right away.

1 Like

Ticket number is #2331527.

Thanks a lot for the help @sdayman .

Had to open another ticket because the first one was not sent from the right email. It was #2331530. That one was also closed because my plan (PRO) does not allow email support.

Any chance to solve this or do I really need to ugprade?

Ok, it seems that going through the dashboard worked.

Ticket is #2331537

Sight… had to create yet another ticket because it seems that if you change the account owner’s address Cloudflare’s support still doesn’t think you are the account owner.

#2331742

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.