Klaviyo is unable to access Orders API - how to allow user agent?

I’m trying to connect the Klaviyo plugin in WordPress to the Klaviyo account but there’s an error message. Their support believes this is a firewall block from the server as per the below response. How to allow their user agent to access the API?

*Do you have any added security or firewalls? Typically when Klaviyo is unable to access the Orders API, it is due to our requests being blocked by the server usually as the result of a firewall or security block. *

In order to resolve this, you must have your team allowlist our Klaviyo user agent. Our user agent is “Klaviyo/1.0”, which is a header that is present on all of our requests.

Thanks, Ramon

I would check the firewall logs to see what is causing the block.
You can make a rule like this, but you will likely have to change it to bypass

Thank you. I disabled Cloudflare temporarily and was able to establish a connection.

If I turn Cloudflare back on, will the API connection be affected? Should I still include your suggested rule?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.