Kemp Load Balancer

Following the NetworkChuck video on setting up a Kemp loadbalancer for home lab access. All going well and within the lab I can access my real hosts via the loadbalancer VIP. However, I can ping my domain but cannot get passed a 522 error trying to get to my origin server.

Why Wait
Don’t wait for an answer, find it fast! Search for #CommunityTip error:
Example: #CommunityTip 521

Test Before You Post
Unsure of the issue? Test before posting using the Cloudflare Diagnostic Center: Diagnostic Center | Check SSL and Test Website Security | Cloudflare

Related to this:

May I ask what have you tried yet due to 522 error?

Does anything changes if you Pause Cloudflare for your domain?
Or temporary switch the :orange: cloud DNS records to :grey: cloud?

There were some cases like, maybe you have got Firewall on the Router or your ISP provider does not support (block) traffic on some port you are trying to work with?

Due to 522 errors, here are usefull tips to troubleshoot:

May I kindly ask to re-check if Cloudflare is allowed to connect to your origin host to as follows in the below article?:

Nevertheless, Cloudflare IP addresses list can be found here:

How about your application(s)?, do they work over a port which is compatible and supported with Cloudflare as follows in the below article:

May I also ask if you have got an SSL certificate for your domain and your sub-domain(s) installed at your host/origin server?
Was it working over HTTPS before moving to Cloudflare?

Here is a way to re-check if you correctly setup the SSL for your domain with Cloudflare:

Can you check what have you got selected under SSL tab at Cloudflare dashboard? Is it Full SSL or something other?

If any other issues appear, follow the needed steps for troubleshooting from article below:

In case you do not have an SSL certificate, you can use Cloudflare SSL, if so, kindly make sure you follow the instructions as follows on the below article to setup an SSL certificate using Cloudflare CA Origin Certificate:

Last but not least, kindly have a look here for more information regarding correct SSL settings:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.