Keep getting “internal issues” error screen on “Mail Routing” / “Routes”

As per the subject.

The issue persists for the 2nd day despite the “Our team has been notified” message, and my submitting the “describe what happened” field a couple of times.

Please see picture:

(if you need the redacted domain name and/or other data to debug/clarify this, please contact me via PM).

While I wait for some answer from Cloudflare (BTW the issue keeps happening and in exactly the same way), I tried to do some diagnosing within my limited perspective, and found that:

  1. Of my 9 domains, the only ones where the issue is not happening are the ones where I have no custom addresses; all domains with custom addresses are getting the error.

  2. I recorded my browser’s screen between the time I clicked on the “Routes” tab to the time the error screen showed up, and then was able to examine it frame-by-frame; I saw that the “Routes” screen loaded almost completely, but right before updating the custom addresses, it went to the error screen

So it seems the error is somewhat connected to my custom addresses.

Can anyone (@simon, or anyone else) from Cloudflare please have a look? Am I doing anything wrong?

Thanks in advance.

Update: I followed on the steps of @user1664 and tried completely deactivating Mail Routing on one of my problem domains (including removing all DNS records), and then activating it back again.

Alas, it did not work for me… :confused:

This is a bug on our side - a fix is currently awaiting release - we’ll update you when it is released.

1 Like

Thanks for the status report, @Simon! Much appreciated!

I was slowly going nuts with the issue and the radio silence.

No problem, AFAICS email is still going thru, so I can wait – but please keep me posted.

1 Like

For the record, since a few hours ago the error stopped happening and I can again access the “Routes” tab in all my domains.

Thanks again!

1 Like