Keep-Alive Not Enabled.?!

Hi. As per GTMetix, Keep Alive is not enabled. I am using Litespeed hosting, and as per hosting support Keep-Alive is enabled from their side. They told me to check with cloudflare. Can someone tell me how to fix this issue.?! Because of that, Too many empty requests getting generated.
Kindly Check this GTMetrix report…
.
GTmetrix](https://gtmetrix.com/reports/techreview.shop/jF8UD1KL/
.
Thank You

To quote this support-page:

HTTP keep-alive (HTTP persistent connection)

Cloudflare maintains keep-alive connections to improve performance and reduce cost of recurring TCP connects in the request transaction as Cloudflare proxies customer traffic from its edge network to the site’s origin.

Ensure HTTP Keep-Alive connections are enabled on your origin. Cloudflare reuses open TCP connections for up to 15 minutes (900 seconds) after the last HTTP request. Origins close TCP connections if too many are open. HTTP Keep-Alive helps avoid premature reset of connections for requests proxied by Cloudflare.

The topic is “Loadbalancing” but anyway this part of “HTTP keep-alive (HTTP persistent connection)” applies to ALL usecases. The origin server have to have to enable HTTP keep-alive (HTTP persistent connection). CloudFlare supports it out of the box, but if your origin server does not have it enabled its not getting used.

Keep Alive is enabled on Origin Server (as i mentioned earlier). But for some reason it is not not working with cloudflare…

Then please test & confirm that it is not just configurated but also working on the origin without getting routed through CloudFlare.

If they say something please confirm it also is true. Set CloudFlare into development mode and run the test again. It the notice still shows up - its not enabled.

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.