Just started with CF and having problems accelerating website


#1

Hi Everyone,

I just joined Cloudflare and it is GREAT.

We have a wordpress website on Godaddy Managed Wordpress.

I have configured DNS with:
One A (root domain for ex domain.com.au) record pointing to the IP address of the godaddy web server
One CNAME www for ex domain.com.au

Using straight DNS and the website loads no problems.

Then I decided to accelerate the website and have installed the cloudflare wordpress plugin, configured the cloudflare signon email address and the global API key, so fa so good.

Then I went to change the status of the above A record and cname to use CDN/Proxy.

I waited a good 15 minutes and when I try to access the web page with a browser for ex. www.domain.com.au I get:

This page isn’t working

I cleared the browser cache and also issued an ipconfig /flushdns, still the same.

The original webserver IP address 198.71.x.x is hidden, because when I ping domain.com.au I get a reply from a Cloudflare Host:

104.27.148.234

What am I doing wrong? Or what is wrong?

I would appreciate some help on this.

Thanks

Best regards

Alfred


#2

That generally sounds good. To check, if your DNS entry here is :grey:, it works, but if you switch it to :orange:, it doesn’t work?

If it’s :grey:, does your site load over HTTPS?

If you’re trying to load over HTTPS, what are your SSL settings here in the Crypto section? Is the SSL Certificate “Active”? Is your SSL setting Flexible, or Full?

What’s the URL?


#3

Hi sdayman,
thanks for your reply.

Just want to premise that I am using a digital ssl certificate from godaddy and installed on their managed wordpress webserver.

If I use straight dns it works fine, but when I toggle the entries for traffic to go through the Cloudflare cloud, I get the page is not working.

Therefore I toggle it back to just DNS and I can load all pages over https.

I never checked the crypto section since I could not find any mention of it on the articles that I read online in setting this up.

The url is vivace.com.au

Currently it is using DNS only no CDN/Proxy in order to work.

PS I checked the crypto section which says:

SSL
Encrypt communication to and from your website using SSL.

It may take up to 24 hours after the site becomes active on Cloudflare for new certificates to issue.

Status Active Certificate, FLEXIBLE

Thanks

Alfred


#4

Hi sdayman,

I read up on the crypto documentation and, because we have a valid Digital SSL Certificate, I decided to set the crypto level to FULL STRICT.

Seems to be working now.

What online tools can I use to check if cloudshare is really caching the website?

GTMETRIX keeps complaining about:

Looks like you might not be using a CDN

Update: now that the website is being accessed via the CF cloud, it seems to be taking a lot longer to load, even gtmetrix shows a higher page load time. Therefore I switch it back to dns.


#5

This topic was automatically closed after 14 days. New replies are no longer allowed.