Just moved from AWS to Cloudflare - internal emails no longer working


#1

Just moved our DNS from AWS to Cloudflare. Internal company emails not working. can send and receive from outside of company but emails within my own domain (between co-workeers) do not go through. Any suggestions?


#2

You probably have a mail-related DNS entry set to :orange:. Cloudflare only proxies HTTP and HTTPS, so if you have something like mail.example.com set to :orange:, it won’t pass email.


#3

Tried removing the proxies even from the A record…still no luck. Any other ideas would be appreciated…
here are my mail related records…

Here’s the SPF string:
v=spf1 include:_spf.google.com ~all

And here are the MX records…


#4

What happens when Internal tries to send? Does it bounce, or does it just refuse to connect? In your mail apps, what are you using for your outbound SMTP server?

Since you can receive emails from outside, it looks like an internal send issue.

I’m bothered by the fact that your domain only has one Cloudflare IP address. When I ‘host’ or ‘nslookup’ your domain, I only get one IP address (plus the MX records). There should be two IP addresses. You should contact Support regarding this issue: login to Cloudflare and then contact Cloudflare Support.


#5

This topic was automatically closed after 31 days. New replies are no longer allowed.