JS and CSS shows error 522 when Caching is on


#1

I am running a wordpress website on my Apache2 Server behind Proxy. Wordpress "/wp-content/plugins/js_composer/assets/js/dist/js_composer_front.min.js**?ver=5.5.2** " doesn’t load and give me error 522 on chrome browser until I Purge Everything from cashing section on cloudeflare or until I load .js file manually without ver=5.5.2 in the browser.

My Caching Level is Standard Browser Cache Expiration is 30 mins. I am not using any chasing on my Proxy Server.

I wonder if someone can help to solve the problem


#2

What’s the domain? Also, here are some community tips for dealing with 522 errors. Community Tip - Fixing Error 522: Connection timed out


#3

Thank you for your reply. I already went through lots of cloudflare’s documents but I am missing something.

Domain name is https://www.pioneercom.co.za and I am getting error on links such as

https://www.pioneercom.co.za/wp-content/plugins/js_composer/assets/js/dist/js_composer_front.min.js?ver=5.5.2

https://www.pioneercom.co.za/wp-content/plugins/js_composer/assets/lib/waypoints/waypoints.min.js?ver=5.5.2

https://www.pioneercom.co.za/wp-includes/js/jquery/ui/tabs.min.js?ver=1.11.4

If you will open a URL without ver=5.5.2 or ver=1.11.4 then .js files will open in the browser it means there is not restriction on IP level and files are accessible.

error


#4

I’m only seeing two errors with mixed content and at my end the social media icons are blocked.


#5

I have been having the same issue. It all works fine in Development Mode. Any ideas?


#6

I opened my website from three different browsers, three different machines and three different WAN links but I am getting same issue everywhere. I am still struggling to find a solution


#7

I get a 200

CloudFlare Inc ECC CA-2
  • SSL certificate verify ok.

GET /wp-content/plugins/js_composer/assets/js/dist/js_composer_front.min.js?ver=5.5.2 HTTP/1.1
User-Agent: curl/7.35.0
Host: www.pioneercom.co.za
Accept: /

< HTTP/1.1 200 OK
< Date: Mon, 28 Jan 2019 07:07:37 GMT
< Content-Type: application/javascript
< Transfer-Encoding: chunked
< Connection: keep-alive
< Set-Cookie: __cfduid=d81a5348ee2ff25139fb12d10870915a11548659256; expires=Tue, 28-Jan-20 07:07:36 GMT; path=/; domain=.pioneercom.co.za; HttpOnly; Secure
< Last-Modified: Sat, 26 Jan 2019 06:36:01 GMT

Damn formatting :roll_eyes:


#8

Development mode is turned Off. I changed Caching Level from “Standard” to “No query string” then Purged Everything now site loading every JS and CSS file. I will test from all three WAN links and machines then will update the community.


#9

Problem still persist.

I tried everything but website doesn’t load properly until I turn on the Development Mode.


#10

Thanks for checking the problem, kindly tell me if you saw any issue in the formatting so I will try to resolve the problem


#11

Unfortunately still struggling with the same issue.

Everything works fine when I turn on my Developer Mode.

I wonder if anyone can help me to find the problem


closed #12

This topic was automatically closed after 14 days. New replies are no longer allowed.