Joomla responsive website - issues with desktop + mobile version


#1

Hello guys,

since I enabled the cloudflare service I am facing some serious issues with my joomla website:

Desktop:

  • my top menu seems in trouble

Mobile:

  • Doesn’t work at all, it keeps showing the desktop version.

Please advise, I am not happy at all with this, and I am afraid that even if I stop the service, my website will still have problems.

Thanks in advance.


#2

Can you post the URL?

Do you have any Page Rules set up in your Cloudflare account?


#3

Hi,

None page rule.

The url is: Benletoni-tours.gr

Thanks

Alex


#4

Only www is currently behind Cloudflare and it does seem to load just fine http://sitemeer.com/#https://www.benletoni-tours.gr.

Though you havent set Cloudflare’s nameservers. You configuration would need a bit of fixing.


#5

I suspect the www-only setup is because it’s a CNAME and their partner host doesn’t let them set up a CNAME for the root domain.

To fix this, add a Page Rule to URL Forward. Match: Benletoni-tours.gr/* and add a Setting to Forward to https://www.Benletoni-tours.gr/$1 (the $1 will forward the path from the non-www site). Then make sure your DNS entry for Benletoni-tours.gr is set to :orange: so it uses Cloudflare’s Page Rules.

Yes, you already set this forwarder on your server, but you should do it on Cloudflare. 1) It’s quicker. 2) It hides your server’s IP address from potential attackers.


#6

Hi,

I set the rule with permanent redirekt.

Tell me please how to change the DNS entry set to Cloudflare?

Thanks

Alex


#7

However I don’t se any changes.

My issue is that my website is responsive, this means that when zoom-in in browser, the site becomes mobile friendly.

Right now it doesn’t work.

I am new in this. I do t know if takes time in order the changes to take effect.

Please let me know if you need any more info for this.

Thanks.

Alex.


#8

Whatever DNS page you’re using, each entry usually has a setting to use or bypass Cloudflare. This page has an example of the DNS settings. The last entry is :grey: with an Activate button. Does your DNS entry for benletoni-tours.gr let your :orange: or Activate?

As for the responsiveness, it’s working for me. On Desktop, it looks great:

In Mobile, it’s also working properly, though the slider is gone and all that’s left is the white stripe:


#9

@sdayman mentioned earlier a partner host. Are you using Cloudflare via your host or did you create your own account? In case of the latter, you’d need to change the nameservers with your registrar. That would be Forthnet, right?


#10

Gah! I forgot the link in my post in reference to Siteground’s DNS settings. The bottom example shows you :orange: and :grey: for DNS entries. Benletoni-tours.gr should be set to :orange: so the Page Rule works.


#11

Hi,

I enabled the service via siteground, where my domain is registered. Forthnet used to be my old host-server.

Should I do any modification?

Thanks.

Alex


#12

Not host, registrar. Where the domain is registered. According to https://grweb.ics.forth.gr/public/whois it is Forthnet.

I cant tell I am afraid, I am not familiar with Siteground and what possible connection they might have with Cloudflare.

Only thing, your naked domain (benletoni-tours.gr) does not point to Cloudflare but to Siteground, but maybe that is intentional.


#13

I believe when you use a Hosting Partner, you’re using their name servers, which are tied into Cloudflare’s name servers. I think his WHOIS configuration for Name Servers is correct.


#14

Hello,

tell me if it’s quite strange what is happening.

Although we made together all proposed changes, in my mozilla the problem remains, in google chrome though the website seems working fine.

The responsive website in safari works fine.

Sorry if I trouble you for nothing, but I really like your cloud service, and I would like to see it working as it should and stay loyal forever!

Thanks


#15

Using Firefox and Chrome on my desktop machine to test responsive layout, they look the same. Can you post screen shots of good and bad views?


#16

This topic was automatically closed after 14 days. New replies are no longer allowed.